summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJia Li2019-08-02 01:29:35 -0400
committerJia Li2019-08-02 01:29:35 -0400
commit216aad9c8e9f828a2ff88917b6b245f5e8b52ada (patch)
tree10b2c6fdbb18e772bc641041828aa282ad4fe7e3
parentd129bbfff383da90701c015f6157090f0d7af09d (diff)
downloadaur-216aad9c8e9f828a2ff88917b6b245f5e8b52ada.tar.gz
Update to 3.0.18
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38fdb252e6ce..ef6122b2714e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libcint-cint3
pkgdesc = General GTO integrals for quantum chemistry (cint3 branch)
- pkgver = 3.0.0
+ pkgver = 3.0.18
pkgrel = 1
url = http://wiki.sunqm.net/libcint
arch = i686
@@ -8,10 +8,10 @@ pkgbase = libcint-cint3
license = BSD
makedepends = cmake
depends = blas
- provides = libcint-cint3=3.0.0
+ provides = libcint-cint3=3.0.18
conflicts = libcint
- source = libcint-cint3::git+https://github.com/sunqm/libcint.git#branch=cint3
- md5sums = SKIP
+ source = https://github.com/sunqm/libcint/archive/v3.0.18.tar.gz
+ sha256sums = c5ecc295f912fd9b80f41c353286172e710ed52ce825d1255d25a0388b6c8ffe
pkgname = libcint-cint3
diff --git a/PKGBUILD b/PKGBUILD
index 1962b9648737..80af8a14ba9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,23 @@
# Maintainer: Jia Li <lijia1608@gmail.com>
pkgname=libcint-cint3
-pkgver=3.0.0
+_pkgname=libcint
+pkgver=3.0.18
pkgrel=1
pkgdesc="General GTO integrals for quantum chemistry (cint3 branch)"
arch=(i686 x86_64)
url="http://wiki.sunqm.net/libcint"
license=('BSD')
+provides=(libcint)
+conflicts=(libcint)
depends=('blas')
makedepends=('cmake')
provides=($pkgname=$pkgver)
conflicts=(libcint)
-source=(${pkgname}::git+https://github.com/sunqm/libcint.git#branch=cint3)
-md5sums=('SKIP')
+source=(https://github.com/sunqm/libcint/archive/v$pkgver.tar.gz)
+sha256sums=('c5ecc295f912fd9b80f41c353286172e710ed52ce825d1255d25a0388b6c8ffe')
build() {
- cd "$pkgname"
+ cd "$_pkgname-$pkgver"
mkdir -p build
cd build
cmake -DWITH_F12=ON -DWITH_RANGE_COULOMB=1 -DWITH_COULOMB_ERF=1 \
@@ -24,6 +27,6 @@ build() {
}
package() {
- cd "$pkgname/build"
+ cd "$_pkgname-$pkgver/build"
make DESTDIR="$pkgdir/" install
}