summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Holfter2015-11-09 16:03:09 +0100
committerAdrian Holfter2015-11-09 16:03:09 +0100
commit2c9e17d4e235d99de5d5a2642dae28c79746356e (patch)
treef40c3d8444ac0c21a2f2c8b1490b4093db653408
downloadaur-2c9e17d4e235d99de5d5a2642dae28c79746356e.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..58cc0c2fcc02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libcitygml
+ pkgdesc = libcitygml is a small and easy to use open source C++ library for parsing CityGML files in such a way that data can be easily exploited by 3D rendering applications.
+ pkgver = 2.0
+ pkgrel = 1
+ url = https://github.com/jklimke/libcitygml
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = cmake
+ depends = glu
+ depends = xerces-c
+ depends = gdal
+ source = https://github.com/jklimke/libcitygml/archive/v2.0.tar.gz
+ md5sums = 7445e1e9976e5cec901ceb4158143bd5
+
+pkgname = libcitygml
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f56db5adade4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Adrian Holfter < aholfter PLUS aur AT googlemail DOT com >
+pkgname=libcitygml
+pkgver=2.0
+pkgrel=1
+pkgdesc="libcitygml is a small and easy to use open source C++ library for parsing CityGML files in such a way that data can be easily exploited by 3D rendering applications."
+arch=('i686' 'x86_64')
+url="https://github.com/jklimke/libcitygml"
+depends=('glu' 'xerces-c' 'gdal')
+makedepends=('cmake')
+license=('LGPL')
+source=(https://github.com/jklimke/libcitygml/archive/v${pkgver}.tar.gz)
+md5sums=('7445e1e9976e5cec901ceb4158143bd5')
+
+build() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir/" install
+
+ # remove bin/citygmlcheck binary
+ cd $pkgdir
+ rm -rf usr/bin
+}