summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLone_Wolf2023-05-14 17:26:29 +0200
committerLone_Wolf2023-05-14 17:26:29 +0200
commit4f142bdd0c0537c2b3ef60734e90c64cfc3e2b43 (patch)
tree7da993a8efac2be16a31fba5b27ec53ffd322e45
parent8e0ad8fd23ffd2a5619181e809aab25b302486c8 (diff)
downloadaur-4f142bdd0c0537c2b3ef60734e90c64cfc3e2b43.tar.gz
removed unnecessary patch, adjusted to llvm-minimal-git changes
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
-rw-r--r--libclc.patch12
3 files changed, 13 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0387dfb33c9b..3bc66a467940 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,20 @@
pkgbase = libclc-minimal-git
pkgdesc = companion package to llvm-minimal-git, Library requirements of the OpenCL C programming language
- pkgver = 17.0.0_r457905.5e53e1bbc34f
- pkgrel = 1
+ pkgver = 17.0.0_r460869.b2809b4811bd
+ pkgrel = 2
url = https://libclc.llvm.org/
arch = any
license = custom:Apache 2.0 with LLVM Exception
makedepends = llvm-minimal-git
+ makedepends = clang-minimal-git
makedepends = cmake
- makedepends = ninja
makedepends = git
makedepends = python
makedepends = spirv-llvm-translator-minimal-git
- makedepends = llvm-libs<16
+ makedepends = llvm-libs<17
provides = libclc
conflicts = libclc
- source = llvm-project::git+https://github.com/llvm/llvm-project.git
- source = libclc.patch
+ source = git+https://github.com/llvm/llvm-project.git
sha256sums = SKIP
- sha256sums = 567e7467923835c1790322b0049efc7dd1962a0600afed66adbdfa545f8a0a8c
pkgname = libclc-minimal-git
diff --git a/PKGBUILD b/PKGBUILD
index 3003e85d2e25..8a9430813862 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,18 @@
# Contributor: Solomon Choina <shlomochoina@gmail.com>
pkgname=libclc-minimal-git
-pkgver=17.0.0_r457905.5e53e1bbc34f
-pkgrel=1
+pkgver=17.0.0_r460869.b2809b4811bd
+pkgrel=2
pkgdesc="companion package to llvm-minimal-git, Library requirements of the OpenCL C programming language"
arch=('any')
url="https://libclc.llvm.org/"
license=('custom:Apache 2.0 with LLVM Exception')
-provides=('libclc')
-conflicts=('libclc')
-makedepends=('llvm-minimal-git' 'cmake' 'ninja' 'git' 'python' 'spirv-llvm-translator-minimal-git' 'llvm-libs<16')
-source=("llvm-project::git+https://github.com/llvm/llvm-project.git"
- libclc.patch)
-sha256sums=('SKIP'
- '567e7467923835c1790322b0049efc7dd1962a0600afed66adbdfa545f8a0a8c')
+provides=(libclc)
+conflicts=(libclc)
+makedepends=(llvm-minimal-git clang-minimal-git cmake git python spirv-llvm-translator-minimal-git 'llvm-libs<17')
+source=("git+https://github.com/llvm/llvm-project.git"
+)
+sha256sums=('SKIP')
pkgver() {
cd llvm-project/llvm
@@ -31,10 +30,6 @@ pkgver() {
echo "${_pkgver}"
}
-prepare() {
- patch --directory="llvm-project" --strip=1 --input="${srcdir}/libclc.patch"
-}
-
build() {
cmake \
-B _build \
diff --git a/libclc.patch b/libclc.patch
deleted file mode 100644
index d7bd4e365c61..000000000000
--- a/libclc.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/libclc/cmake/CMakeLLAsmInformation.cmake b/libclc/cmake/CMakeLLAsmInformation.cmake
-index 218e20a52fe8..617e531b1d12 100644
---- a/libclc/cmake/CMakeLLAsmInformation.cmake
-+++ b/libclc/cmake/CMakeLLAsmInformation.cmake
-@@ -1,6 +1,6 @@
- if(NOT CMAKE_LLAsm_COMPILE_OBJECT)
- set(CMAKE_LLAsm_COMPILE_OBJECT
-- "${CMAKE_LLAsm_PREPROCESSOR} -E -P <DEFINES> <INCLUDES> <FLAGS> -x cl <SOURCE> -o <OBJECT>.temp"
-+ "${CMAKE_LLAsm_PREPROCESSOR} -E -P <DEFINES> <INCLUDES> <FLAGS> -cl-no-stdinc -x cl <SOURCE> -o <OBJECT>.temp"
- "<CMAKE_LLAsm_COMPILER> -o <OBJECT> <OBJECT>.temp")
- endif()
-