summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCzipperz2017-05-14 19:49:56 -0700
committerCzipperz2017-05-14 19:49:56 -0700
commit49a388887473c332e64348dc6d60ea756310abb2 (patch)
tree623470ad1409b46a089bc53f8d4f19601953a2f8
downloadaur-49a388887473c332e64348dc6d60ea756310abb2.tar.gz
Init
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8cc97a27bff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libclipboard-git
+ pkgdesc = Lightweight cross-platform C clipboard library
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/czipperz/libclipboard
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = git
+ depends = libxcb
+ provides = libclipboard
+ source = git://github.com/czipperz/libclipboard
+ sha256sums = SKIP
+
+pkgname = libclipboard-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d0f733c3e2a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Chris Gregory <czipperz@gmail.com>
+pkgname=libclipboard-git
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Lightweight cross-platform C clipboard library"
+url="https://github.com/czipperz/libclipboard"
+arch=("i686" "x86_64")
+license=("MIT")
+depends=("libxcb")
+makedepends=("cmake" "git")
+provides=("libclipboard")
+source=("git://github.com/czipperz/libclipboard")
+sha256sums=("SKIP")
+
+build() {
+ cd libclipboard
+ cmake . -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd libclipboard
+ make DESTDIR="${pkgdir}" install
+}