summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaco Malan2019-11-08 17:40:43 +0200
committerJaco Malan2019-11-08 17:40:43 +0200
commitd3f13f70e4b1dbedd3ebe7b97f739bf3a16119c6 (patch)
tree42b1d290663f996416b8b1fabc9080dfa53e92ad
downloadaur-d3f13f70e4b1dbedd3ebe7b97f739bf3a16119c6.tar.gz
Initial Commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD37
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4751b4aed717
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = libclstl-git
+ pkgdesc = The CodeLog Standard Template Library
+ pkgver = r2.f9a4560
+ pkgrel = 1
+ url = https://github.com/Code-Log/clstl
+ arch = any
+ license = MIT
+ makedepends = clang
+ makedepends = git
+ source = libclstl::git+https://github.com/Code-Log/clstl#branch=master
+ md5sums = SKIP
+
+pkgname = libclstl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b387c2ad07fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Jaco Malan <jacomalan.12@gmail.com>
+pkgname=libclstl-git
+pkgrel=1
+pkgver=r2.f9a4560
+pkgdesc="The CodeLog Standard Template Library"
+arch=('any')
+url="https://github.com/Code-Log/clstl"
+license=('MIT')
+makedepends=('clang' 'git')
+source=('libclstl::git+https://github.com/Code-Log/clstl#branch=master')
+
+pkgver() {
+
+ cd $srcdir
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
+}
+
+prepare() {
+ mkdir -p $srcdir/libclstl/build
+}
+
+build() {
+
+ cd $srcdir/libclstl/build
+ cmake .. -DCMAKE_BUILD_TYPE=Release -DCMAKE_C_COMPILER=$(which clang) -DCMAKE_CXX_COMPILER=$(which clang++)
+ make $MAKEFLAGS
+
+}
+
+package() {
+
+ cd $srcdir/libclstl/build
+ make DESTDIR="$pkgdir" install
+
+}
+md5sums=('SKIP')