summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2018-12-18 15:16:21 +0000
committerEric Engestrom2018-12-18 15:16:21 +0000
commit058b6751f20fcf7f5d2323453a9d6455708b6547 (patch)
treee66c972eeb2c3c2337355a05327370e89e9325da
parentb7bac54a12e7d798c6007d4e1a86ef49c9efe4da (diff)
downloadaur-058b6751f20fcf7f5d2323453a9d6455708b6547.tar.gz
HACK: put DESTDIR inside the prefix as it's the only solution supported on BSD
-rw-r--r--PKGBUILD16
1 files changed, 2 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cc958e72e105..0d3ec5893b3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,7 +22,7 @@ pkgver() {
prepare() {
cd pkgcenter/depend/libcmb
- ./configure --prefix /usr
+ ./configure --prefix "$pkgdir/usr"
}
build() {
@@ -32,17 +32,5 @@ build() {
package() {
cd pkgcenter/depend/libcmb
-
- # Disabled for now because DESTDIR isn't respected
- #DESTDIR="$pkgdir" make install
-
- install -dm755 "$pkgdir"/usr/lib
- install -m755 libcmb.so.* "$pkgdir"/usr/lib/
- ln -s libcmb.so.* "$pkgdir"/usr/lib/libcmb.so
-
- install -dm755 "$pkgdir"/usr/include
- install -m444 cmb.h "$pkgdir"/usr/include/
-
- install -dm755 "$pkgdir"/usr/share/man/man3
- install -m444 cmb.3.gz "$pkgdir"/usr/share/man/man3/
+ make install
}