summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Hipp2019-08-05 18:23:55 +0200
committerThomas Hipp2019-08-05 22:30:35 +0200
commit835aeee3ba34467d85075c3722d5732a9234650a (patch)
treecb236f7cb694db9ea974266351ed07479239cf15
downloadaur-835aeee3ba34467d85075c3722d5732a9234650a.tar.gz
Initial commit
Signed-off-by: Thomas Hipp <thomashipp@gmail.com>
-rw-r--r--.SRCINFO14
-rw-r--r--LICENSE45
-rw-r--r--PKGBUILD26
3 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..154306156b60
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = libco
+ pkgdesc = Cooperative multithreading library
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/canonical/libco
+ arch = x86_64
+ license = custom
+ source = https://github.com/canonical/libco/archive/v1.0.2.tar.gz
+ source = LICENSE
+ sha256sums = 8876aa8e61f07b37adb3ad422b369ecf9bf6fad20ce691428c35719ba5f16615
+ sha256sums = 8938af6b9204bd76eccc205b1e62829ab6d0973d33038db4423903640e5bca64
+
+pkgname = libco
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..fcb4233b3c4e
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,45 @@
+----------------------------------------------------------------------
+higan - Suite of videogame emulators
+icarus - Game library importer for higan
+genius - Game database editor for higan
+
+ Copyright © 2004-2019 byuu
+
+ https://byuu.org
+
+This program is free software: you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation, specifically version 3 of the License
+and no other version.
+
+This program is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+along with this program. If not, see <https://www.gnu.org/licenses/>.
+----------------------------------------------------------------------
+
+----------------------------------------------------------------------
+libco - C cooperative threading library
+nall - C++ template library
+ruby - Hardware abstraction library
+hiro - User interface library
+
+ Copyright © 2006-2019 byuu
+
+Permission to use, copy, modify, and/or distribute this software for
+any purpose with or without fee is hereby granted, provided that the
+above copyright notice and this permission notice appear in all
+copies.
+
+THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL
+WARRANTIES WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED
+WARRANTIES OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE
+AUTHOR BE LIABLE FOR ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL
+DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR
+PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+PERFORMANCE OF THIS SOFTWARE.
+----------------------------------------------------------------------
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce350e254498
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Thomas Hipp <thomashipp at gmail dot com>
+pkgname=libco
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Cooperative multithreading library"
+arch=('x86_64')
+url="https://github.com/canonical/libco"
+license=('custom')
+source=("https://github.com/canonical/${pkgname}/archive/v${pkgver}.tar.gz"
+ "LICENSE")
+sha256sums=('8876aa8e61f07b37adb3ad422b369ecf9bf6fad20ce691428c35719ba5f16615'
+ '8938af6b9204bd76eccc205b1e62829ab6d0973d33038db4423903640e5bca64'
+)
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 libco.so "${pkgdir}/usr/lib/libco.so"
+ install -Dm644 libco.h "${pkgdir}/usr/include/libco.h"
+ install -Dm644 libco.pc "${pkgdir}/usr/lib/pkgconfig/libco.pc"
+ install -Dm644 "${srcdir}"/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}