summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Brennan2021-05-28 09:02:30 -0700
committerStephen Brennan2021-05-28 09:02:30 -0700
commit02037b41c8f6117cafd4f4720cadad4a66748c50 (patch)
treeca5db6529500ffe8a0a92dcd505d6a72dc76ebc7
parent90b3842c4a069e9e2b38eee52bf8c6b2fb891c42 (diff)
downloadaur-02037b41c8f6117cafd4f4720cadad4a66748c50.tar.gz
Update to 3.6.0, apply some feedback
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
2 files changed, 23 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f622aa4719b4..3525c7434a0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
-# Generated by mksrcinfo v8
-# Wed Feb 22 16:01:29 UTC 2017
pkgbase = libcommuni
pkgdesc = A cross-platform IRC framework written with Qt.
- pkgver = 3.5.0
+ pkgver = 3.6.0
pkgrel = 1
url = https://communi.github.io/
- arch = any
- license = custom
+ arch = x86_64
+ arch = i686
+ arch = aarch64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = BSD
+ makedepends = chrpath
depends = qt5-declarative
- provides = libcommuni
- conflicts = libcommuni
- source = libcommuni-v3.5.0.tar.gz::https://github.com/communi/libcommuni/archive/v3.5.0.tar.gz
- md5sums = 2b62f599800962b2350cbd7ca2fc05ae
+ source = libcommuni-v3.6.0.tar.gz::https://github.com/communi/libcommuni/archive/v3.6.0.tar.gz
+ md5sums = 34d7a865ecac8d444ee2433491df5634
pkgname = libcommuni
diff --git a/PKGBUILD b/PKGBUILD
index 862571269d22..86009142194c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,16 @@
# Maintainer: Stephen Brennan <smb196@case.edu>
+# Contributor: Arvedui <arvedui@posteo.de>
pkgname=libcommuni
-pkgver=3.5.0
+pkgver=3.6.0
pkgrel=1
-epoch=
pkgdesc="A cross-platform IRC framework written with Qt."
-arch=('any')
+arch=('x86_64' 'i686' 'aarch64' 'arm' 'armv6h' 'armv7h')
url="https://communi.github.io/"
-license=('custom')
-groups=()
+license=('BSD')
depends=('qt5-declarative')
-makedepends=()
-checkdepends=()
-optdepends=()
-provides=($pkgname)
-conflicts=($pkgname)
-replaces=()
-backup=()
-options=()
-install=
-changelog=
+makedepends=('chrpath')
source=("libcommuni-v$pkgver.tar.gz::https://github.com/communi/$pkgname/archive/v$pkgver.tar.gz")
-noextract=()
-md5sums=(2b62f599800962b2350cbd7ca2fc05ae)
-validpgpkeys=()
+md5sums=(34d7a865ecac8d444ee2433491df5634)
build() {
cd "$pkgname-$pkgver"
@@ -38,7 +26,10 @@ check() {
package() {
cd "$pkgname-$pkgver"
make INSTALL_ROOT="$pkgdir" install
- mkdir -p "$pkgdir/usr/share/licenses/${pkgname}/"
- install -m644 LICENSE \
- "$pkgdir/usr/share/licenses/${pkgname}/"
+ mkdir -p "$pkgdir/usr/share/licenses/${pkgname}/"
+ install -m644 LICENSE \
+ "$pkgdir/usr/share/licenses/${pkgname}/"
+
+ chrpath -d "${pkgdir}/usr/lib/libIrc"{Model,Util}".so.${pkgver}"
+ chrpath -d "${pkgdir}/usr/lib/qt/qml/Communi/libcommuniplugin.so"
}