summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrufo2017-10-01 18:07:31 +0100
committergrufo2017-10-01 18:07:31 +0100
commit386e790b06d015a6e0c31dcbde90f3eef2b9b7a6 (patch)
treefaaec7dd0d974360c11602ff0f29b7f857ec9895
downloadaur-386e790b06d015a6e0c31dcbde90f3eef2b9b7a6.tar.gz
First commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD53
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aebb5968cc54
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libconfini-git
+ pkgdesc = Yet another INI parser
+ pkgver = r74.43c29b3
+ pkgrel = 1
+ url = https://madmurphy.github.io/libconfini/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ provides = libconfini
+ conflicts = libconfini
+ source = git+https://github.com/madmurphy/libconfini.git
+ md5sums = SKIP
+
+pkgname = libconfini-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02709eb59850
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: grufo <madmurphy333@gmail.com>
+
+pkgname='libconfini-git'
+_pkgname='libconfini'
+pkgver='r74.43c29b3'
+pkgrel=1
+pkgdesc='Yet another INI parser'
+arch=('i686' 'x86_64')
+url='https://madmurphy.github.io/libconfini/'
+license=('GPL')
+makedepends=('intltool')
+provides=('libconfini')
+conflicts=('libconfini')
+source=("git+https://github.com/madmurphy/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+
+ cd "${_pkgname}"
+ printf "'r%s.%s'" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
+}
+
+prepare() {
+
+ cd "${srcdir}/${_pkgname}"
+ ./autogen.sh
+ ./configure --prefix=/usr CFLAGS='-pedantic -std=c99 -g -O3'
+
+}
+
+build() {
+
+ cd "${srcdir}/${_pkgname}"
+ make
+
+}
+
+check() {
+
+ cd "${srcdir}/${_pkgname}"
+ make check
+
+}
+
+package() {
+
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+ chmod +x "${pkgdir}/usr/share/doc/${_pkgname}/examples/run_example.sh"
+
+}
+