summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlphaJack2024-02-24 19:55:10 +0100
committerAlphaJack2024-02-24 19:55:10 +0100
commit733b5c1328326876872b8b20c8b8219e533ecd37 (patch)
tree75ec8fb90d4c3911dd04900ad3e30e34d58bd0e3
parent0ae2ef58e0e558d4cf3f42aeb3b8971aaa9912bc (diff)
downloadaur-733b5c1328326876872b8b20c8b8219e533ecd37.tar.gz
Patched ccrng_entropy.c
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68524a951aa4..2e83ceb08276 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libcorecrypto
pkgdesc = Library implementing Apple low-level cryptographic primitives
pkgver = 2022
- pkgrel = 2
+ pkgrel = 3
url = https://developer.apple.com/security/
arch = x86_64
arch = armv7h
diff --git a/PKGBUILD b/PKGBUILD
index 0b0d3c5377a5..d69603936a88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: AlphaJack <alphajack at tuta dot io>
pkgname="libcorecrypto"
-# curl -s https://developer.apple.com/security/ | grep 'rel="/file/?file=security&agree=Yes"' | cut -d "(" -f2 | cut -d ")" -f1 | grep -o '[0-9]\+'
+# when apple breaks the checksum, run
+# curl -s https://developer.apple.com/security/ | grep 'rel="/file/?file=security&agree=Yes"' | cut -d "(" -f2 | cut -d ")" -f1 | grep -o '[0-9]\+'
pkgver=2022
-pkgrel=2
+pkgrel=3
pkgdesc="Library implementing Apple low-level cryptographic primitives"
url="https://developer.apple.com/security/"
license=("custom")
@@ -47,6 +48,10 @@ prepare(){
b2sum --check --quiet "corecrypto.zip.b2" || return 1
echo " corecrypto.zip. ... Passed"
bsdtar --extract --file "corecrypto.zip"
+ # avoid errors, as per https://github.com/NyaMisty/AltServer-Linux/
+ sed '/corecrypto_perf\|corecrypto_test/d' -i "corecrypto/build/CMakeFiles/Makefile2"
+ # avoid errror, as per https://aur.archlinux.org/packages/libcorecrypto-git
+ sed 's|CC_MARK_MEMORY_PUBLIC|//&|' -i "corecrypto/ccrng/src/ccrng_entropy.c"
}
build(){
@@ -59,9 +64,7 @@ build(){
-DCMAKE_BUILD_TYPE="Release" \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INSTALL_LIBDIR="lib" \
- -Wno-dev \
- # avoid errors, as per https://github.com/NyaMisty/AltServer-Linux/
- sed '/corecrypto_perf\|corecrypto_test/d' -i "build/CMakeFiles/Makefile2"
+ -Wno-dev
cmake --build "build" -j "$(nproc)"
}