summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Johansen2019-09-16 15:24:33 +0200
committerDan Johansen2019-09-16 15:24:33 +0200
commit3d10e6a8302097aba928aac47babb5e07b8aba17 (patch)
treec031bface8f9631b3b26ccae7221342176ab1a4f
downloadaur-3d10e6a8302097aba928aac47babb5e07b8aba17.tar.gz
initial commit, version 2.7
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b7dd8512510
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libcprime
+ pkgdesc = A library for bookmarking, saving recent activites, managing settings of CoreApps.
+ pkgver = 2.7.0
+ pkgrel = 1
+ url = https://gitlab.com/cubocore/libcprime
+ arch = x86_64
+ arch = aarch64
+ groups = coreapps
+ license = GPL3
+ depends = qt5-base
+ depends = qt5-connectivity
+ depends = libnotify
+ source = https://gitlab.com/cubocore/libcprime/-/archive/v2.7.0/libcprime-v2.7.0.tar.gz
+ md5sums = 42a83fb6464f9f3066707e17d925ae9a
+
+pkgname = libcprime
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae27169b5e21
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Shaber
+# Maintainer: Dan Johansen <strit@manjaro.org>
+
+pkgname=libcprime
+pkgver=2.7.0
+pkgrel=1
+pkgdesc="A library for bookmarking, saving recent activites, managing settings of CoreApps."
+arch=('x86_64' 'aarch64')
+url="https://gitlab.com/cubocore/$pkgname"
+license=('GPL3')
+depends=('qt5-base' 'qt5-connectivity' 'libnotify')
+groups=('coreapps')
+source=("https://gitlab.com/cubocore/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
+md5sums=('42a83fb6464f9f3066707e17d925ae9a')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd ${pkgname}-v${pkgver}
+
+ qmake-qt5 ${pkgname}.pro
+ make
+}
+
+package() {
+ cd ${pkgname}-v${pkgver}
+ make INSTALL_ROOT=${pkgdir} install
+}