summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthur Poulet2018-05-27 20:54:20 +0200
committerArthur Poulet2018-05-27 22:24:41 +0200
commit63f96b1d841c022434d331e7548025cf4ab7ce62 (patch)
tree00fda99cb1fb90d6a6a50ddb0016d551026ff9c2
downloadaur-63f96b1d841c022434d331e7548025cf4ab7ce62.tar.gz
Init package on libcredid v0.3.5
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD36
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b1988a1c9152
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = libcredid
+ pkgdesc = C Binding for credid client
+ pkgver = v0.3.5.r0.02b654e
+ pkgrel = 1
+ url = https://github.com/Credid/c-credid-api
+ arch = any
+ license = GPLv3
+ makedepends = cmake gcc
+ source = c-credid-api::git+https://github.com/Credid/c-credid-api
+ md5sums = SKIP
+
+pkgname = libcredid
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0c62ae59c016
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*/
+*.pkg.tar
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35db5bf2f506
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Arthur Poulet (arthur.poulet@sceptique.eu)
+pkgname=libcredid
+pkgver=v0.3.5.r0.02b654e
+pkgrel=1
+pkgdesc="C Binding for credid client"
+arch=('any')
+url="https://github.com/Credid/c-credid-api"
+license=('GPLv3')
+groups=()
+depends=()
+makedepends=('cmake gcc')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=('c-credid-api::git+https://github.com/Credid/c-credid-api')
+#source=('c-credid-api.tar.gz::http://localhost/transfer_more_pkg/c-credid-api.tar.xz')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/c-credid-api"
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir/c-credid-api"
+ make
+}
+
+package() {
+ cd "$srcdir/c-credid-api"
+ make PREFIX="$pkgdir/usr/local" install
+}