summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2017-04-04 21:11:49 -0500
committerDan Beste2017-04-04 21:15:47 -0500
commit57a557596827f360c2623282f347da6c8604c8c2 (patch)
tree63661e04d579bdf594247b39fd59263e13edf30f
parent58b93aa2867525361ec84579b440a35971232363 (diff)
downloadaur-57a557596827f360c2623282f347da6c8604c8c2.tar.gz
PKGBUILD - Remove unneeded code
Removed '|| exit 1' statements. makepkg will bail out if a command fails. Shortened 'cd' commands.
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1ef2d72f8437..9335c61d0662 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,10 @@
# Maintainer : Dan Beste <dan.ray.beste@gmail.com>
# Contributor : Jestine Paul <jestine dot paul at gmail dot com>
-pkgname=libcs50-git
-gitname=libcs50
+pkgname='libcs50-git'
+gitname='libcs50'
pkgver=r137.8a353ba
pkgrel=1
-epoch=
pkgdesc="CS50 Library for C"
arch=('x86_64' 'i686')
url="https://cs50.harvard.edu/"
@@ -15,11 +14,11 @@ depends=('glibc')
makedepends=('git')
provides=('libcs50')
conflicts=('libcs50')
-source=(git+https://github.com/cs50/libcs50.git)
+source=('git+https://github.com/cs50/libcs50.git')
md5sums=('SKIP')
pkgver() {
- cd "${srcdir}/${gitname}" || exit 1
+ cd "${gitname}"
printf "r%s.%s" \
"$(git rev-list --count HEAD)" \
@@ -27,13 +26,13 @@ pkgver() {
}
build() {
- cd "${srcdir}/${gitname}" || exit 1
+ cd "${gitname}"
make build
}
package() {
- cd "${srcdir}/${gitname}" || exit 1
+ cd "${gitname}"
- rsync -rpv build/* "${pkgdir}"
+ cp -rp build/* "${pkgdir}"
}