summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEdmund2024-01-17 16:20:49 +0200
committerEdmund2024-01-17 16:20:49 +0200
commitb802d26c05c7ee2fff23dd35c44496f150ab478f (patch)
treee930fcf380b5447873c3448b7b6a38678f1809c8
parent5c35b67685aa667decf12e6163dc039d9e917a73 (diff)
downloadaur-b802d26c05c7ee2fff23dd35c44496f150ab478f.tar.gz
Updated SPDX license format. Added install text.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--libcs50.install1
3 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b131b79b568..f6c0fd63c952 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libcs50-git
pkgdesc = CS50 Library for C (development version)
- pkgver = 11.0.1.r4.gc5bead0
- pkgrel = 3
+ pkgver = 11.0.2.r0.g6d916ef
+ pkgrel = 2
url = https://github.com/cs50/libcs50
install = libcs50.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 13abde4cd55b..3ffb3d7c8557 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
pkgname='libcs50-git'
_gitname='libcs50'
-pkgver=11.0.1.r4.gc5bead0
-pkgrel=3
+pkgver=11.0.2.r0.g6d916ef
+pkgrel=2
pkgdesc="CS50 Library for C (development version)"
arch=('x86_64' 'i686')
url="https://github.com/cs50/libcs50"
@@ -36,6 +36,7 @@ prepare() {
cd "${_gitname}"
patch < "${srcdir}/Makefile.patch"
+# patch < "${srcdir}/Makefile-CFLAGS.patch"
}
build() {
@@ -44,6 +45,7 @@ build() {
# TODO: Get this fixed upstream. We should not have to unset our $CFLAGS and
# $MAKEFLAGS.
CFLAGS= MAKEFLAGS= make
+ make
}
package() {
@@ -52,6 +54,7 @@ package() {
# TODO: Get this fixed upstream. We should not have to unset our $CFLAGS and
# $MAKEFLAGS.
CCFLAGS= MAKEFLAGS= DESTDIR="${pkgdir}/usr" make install
+ DESTDIR="${pkgdir}/usr" make install
rm "${pkgdir}/usr/src/cs50.c"
install -d -m 755 "${pkgdir}/usr/src/libcs50"
diff --git a/libcs50.install b/libcs50.install
index e2c4ebb13c09..4c72953b0a6c 100644
--- a/libcs50.install
+++ b/libcs50.install
@@ -2,4 +2,5 @@ post_install() {
echo -e 'SUGGESTION:\n'
echo -e '\nInstead of using a makefile, you can add the following alias to your ~/.bashrc:'
echo -e " "alias make50="'"'make CC=clang CFLAGS="-fsanitize=signed-integer-overflow -fsanitize=undefined -ggdb3 -O0 -std=c11 -Wall -Werror -Wextra -Wno-sign-compare -Wno-unused-parameter -Wno-unused-variable -Wshadow" LDLIBS="-lcrypt -lcs50 -lm"'"'"'\n'
+ echo -e '\nThis would require having `clang` installed.'
}