summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlibrewish2020-01-24 23:26:29 +0530
committerlibrewish2020-01-24 23:26:29 +0530
commit164127f05d40faf76c428121652dc8a06f4c6282 (patch)
tree4ed204106b5b45df491a38dbae259068341d987f
downloadaur-164127f05d40faf76c428121652dc8a06f4c6282.tar.gz
init
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..03d41e741ece
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libcsys-git
+ pkgdesc = Library for managing drive and getting system resource information in real time.
+ pkgver = v2.8.0.r0.feb9591
+ pkgrel = 1
+ url = https://gitlab.com/cubocore/libcsys
+ arch = i686
+ arch = x86_64
+ groups = coreapps-git
+ license = GPL
+ makedepends = git
+ depends = qt5-base
+ provides = libcsys
+ conflicts = libcsys
+ source = git+https://gitlab.com/cubocore/libcsys.git
+ md5sums = SKIP
+
+pkgname = libcsys-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c5be0483c16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+_pkgname=libcsys
+pkgname=${_pkgname}-git
+pkgver=v2.8.0.r0.feb9591
+pkgrel=1
+pkgdesc="Library for managing drive and getting system resource information in real time."
+arch=('i686' 'x86_64')
+url="https://gitlab.com/cubocore/libcsys"
+license=('GPL')
+depends=('qt5-base' )
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+groups=('coreapps-git')
+source=("git+https://gitlab.com/cubocore/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ qmake-qt5 ${_pkgname}.pro
+ make
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ make INSTALL_ROOT=${pkgdir} install
+}