summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Heitzmann Gabrielli2015-08-12 21:17:24 -0300
committerLucas Heitzmann Gabrielli2015-08-12 21:17:24 -0300
commit7a304016db5f64ee251c0201f916c31f9a9fcf5e (patch)
tree43bd96bebc9ce4a1d1a730a421cc45e6c4ff57ef
downloadaur-7a304016db5f64ee251c0201f916c31f9a9fcf5e.tar.gz
Adopting and updating to 3.2.2
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD25
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e62c118664c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libctl
+ pkgdesc = A free Guile-based library implementing flexible control files for scientific simulations.
+ pkgver = 3.2.2
+ pkgrel = 1
+ url = http://ab-initio.mit.edu/wiki/index.php/Libctl
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = guile
+ options = !libtool
+ source = http://ab-initio.mit.edu/libctl/libctl-3.2.2.tar.gz
+ md5sums = 5fd7634dc9ae8e7fa70a68473b9cbb68
+
+pkgname = libctl
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..888883e85236
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg
+src
+libctl-*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f7d92e42d86
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Tom K <tomk@runbox.com>
+# Maintainer: Aaron Ali <t0nedef@causal.ca>
+# Maintainer: Lucas H. Gabrielli <heitzmann@gmail.com>
+
+pkgname=libctl
+pkgver=3.2.2
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc="A free Guile-based library implementing flexible control files for scientific simulations."
+depends=('guile')
+source=(http://ab-initio.mit.edu/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('5fd7634dc9ae8e7fa70a68473b9cbb68')
+url="http://ab-initio.mit.edu/wiki/index.php/Libctl"
+license=('GPL')
+options=('!libtool')
+
+build() {
+ cd ${srcdir}/$pkgname-$pkgver
+ ./configure --prefix=/usr LIBS="-lm"
+ make
+}
+package() {
+ cd ${srcdir}/$pkgname-$pkgver
+ make DESTDIR=${pkgdir} install
+}