summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Heitzmann Gabrielli2017-11-14 07:36:20 -0200
committerLucas Heitzmann Gabrielli2017-11-14 07:36:20 -0200
commit693aaf8d463ff0d9a4890a359d24fdfce91f9579 (patch)
tree121278c6180bf0093285788d68b5ebffe927e0e5
downloadaur-693aaf8d463ff0d9a4890a359d24fdfce91f9579.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ac490fc6e0a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libctl-git
+ pkgdesc = Guile-based library implementing flexible control files for scientific simulations
+ pkgver = 3.2.2.r20.ga1bde30
+ pkgrel = 1
+ url = https://github.com/stevengj/libctl
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = guile
+ depends = gcc-fortran
+ provides = libctl
+ conflicts = libctl
+ options = !libtool
+ source = git+https://github.com/stevengj/libctl.git
+ sha256sums = SKIP
+
+pkgname = libctl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e290b9481da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Lucas H. Gabrielli <heitzmann@gmail.com>
+pkgname=libctl-git
+pkgver=3.2.2.r20.ga1bde30
+pkgrel=1
+pkgdesc='Guile-based library implementing flexible control files for scientific simulations'
+arch=('i686' 'x86_64')
+url='https://github.com/stevengj/libctl'
+license=('GPL2')
+depends=('guile' 'gcc-fortran')
+options=('!libtool')
+provides=('libctl')
+conflicts=('libctl')
+source=('git+https://github.com/stevengj/libctl.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/libctl"
+ git describe --long --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/libctl"
+ sed -i '/unknown argument/d' autogen.sh
+ #./autogen.sh F77=gfortran CC=gcc CXX=g++ LIBS='-lm' GUILE='/usr/bin/guile2.0' GUILE_CONFIG='/usr/bin/guile-config2.0' --prefix=/usr --enable-shared
+ #./autogen.sh F77=gfortran CC=gcc CXX=g++ LIBS='-lm' --prefix=/usr --enable-shared
+ ./autogen.sh LIBS='-lm' --prefix=/usr --enable-shared
+ make
+}
+
+package() {
+ cd "${srcdir}/libctl"
+ make DESTDIR=${pkgdir} install
+}