summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiguel Revilla2015-07-02 16:53:02 +0200
committerMiguel Revilla2015-07-02 16:53:02 +0200
commit07c8858b06ed55a25d7eacd688fc9514763d523a (patch)
tree01c6497eb436960990346e238e2c3cd09bbbd450
downloadaur-07c8858b06ed55a25d7eacd688fc9514763d523a.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6edce2f736f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libcutl
+ pkgdesc = A C++ utility library
+ pkgver = 1.9.0
+ pkgrel = 1
+ url = http://www.codesynthesis.com/projects/libcutl/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = gcc-libs
+ options = !libtool
+ source = http://www.codesynthesis.com/download/libcutl/1.9/libcutl-1.9.0.tar.bz2
+ md5sums = 54cf1f421a520e79dd06c436a8b968d3
+
+pkgname = libcutl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba7355a8c00e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Miguel Revilla <yo@miguelrevilla.com>
+# Contributor: Miguel Revilla <yo@miguelrevilla.com>
+
+pkgname=libcutl
+pkgver=1.9.0
+pkgrel=1
+pkgdesc="A C++ utility library"
+arch=('i686' 'x86_64')
+depends=('gcc-libs')
+url="http://www.codesynthesis.com/projects/libcutl/"
+options=('!libtool')
+license=('MIT')
+source=("http://www.codesynthesis.com/download/libcutl/1.9/libcutl-${pkgver}.tar.bz2")
+md5sums=('54cf1f421a520e79dd06c436a8b968d3')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure --prefix=/usr
+ make ECHO=echo
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make ECHO=echo DESTDIR="${pkgdir}" install
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}