summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Lisin2019-09-21 16:51:47 +0200
committerMatthias Lisin2019-09-21 16:51:47 +0200
commit05c3a6b6abeb1549b3ae3dd531a033a5e7608959 (patch)
treee3edade8a4160d3ffe831cfdf2809937f89bc5c6
downloadaur-05c3a6b6abeb1549b3ae3dd531a033a5e7608959.tar.gz
create: libcvtapi-git
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8a23540d2ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libcvtapi-git
+ pkgdesc = Official implementation of the VirusTotal API in C programming language
+ pkgver = r135.dae474e
+ pkgrel = 1
+ url = https://github.com/VirusTotal/c-vtapi
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ depends = curl
+ depends = jansson
+ provides = libcvtapi.so
+ conflicts = libcvtapi
+ source = libcvtapi-git::git+https://github.com/VirusTotal/c-vtapi
+ sha512sums = SKIP
+
+pkgname = libcvtapi-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f61aa9f1e39
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Matthias Lisin <ml@visu.li>
+pkgname=libcvtapi-git
+pkgver=r135.dae474e
+pkgrel=1
+pkgdesc='Official implementation of the VirusTotal API in C programming language'
+arch=(i686 x86_64)
+url=https://github.com/VirusTotal/c-vtapi
+license=(Apache)
+groups=()
+depends=(curl jansson)
+makedepends=(git) # 'bzr', 'git', 'mercurial' or 'subversion'
+provides=(libcvtapi.so)
+conflicts=(libcvtapi)
+source=("$pkgname::git+$url")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+build() {
+ cd "$pkgname"
+ autoreconf -fi
+ ./configure --disable-doxygen-doc --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir/" install
+}