summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Kalb2015-05-30 23:25:58 +0200
committerMarkus Kalb2015-05-30 23:25:58 +0200
commitb73bc6cd4dfcec5770fedaef1095d627b2014830 (patch)
tree4dbcbb7e1a67f7a856e9fb795f13e7216154e8b5
downloadaur-b73bc6cd4dfcec5770fedaef1095d627b2014830.tar.gz
Initial import - Version 0.11.0-4
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..817da98ebe6f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libcxml
+ pkgdesc = A small C++ library which makes it marginally neater to parse XML using libxml++
+ pkgver = 0.11.0
+ pkgrel = 4
+ url = http://carlh.net/software/libcxml/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = python2
+ makedepends = pkg-config
+ makedepends = boost
+ depends = libxml++>=2.6
+ depends = boost-libs
+ source = libcxml.tar.bz2::http://carlh.net/downloads/libcxml/libcxml-0.11.0.tar.bz2
+ sha256sums = 1c5c8bdbc77a19c02b0f783fa774ce33414ebd1c13f7dc276ae63dc010e639c6
+
+pkgname = libcxml
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4cff1418735d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Markus Kalb <mk@filmkreis.tu-darmstadt.de>
+# Contributor: Stefan Karner <stefan.karner@student.tuwien.ac.at>
+pkgname=libcxml
+pkgver=0.11.0
+pkgrel=4
+pkgdesc="A small C++ library which makes it marginally neater to parse XML using libxml++"
+arch=('i686' 'x86_64')
+url="http://carlh.net/software/libcxml/"
+license=('GPL')
+groups=
+depends=('libxml++>=2.6' 'boost-libs')
+makedepends=('python2' 'pkg-config' 'boost')
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=("${pkgname}.tar.bz2::http://carlh.net/downloads/libcxml/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('1c5c8bdbc77a19c02b0f783fa774ce33414ebd1c13f7dc276ae63dc010e639c6')
+
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ python2 waf configure --prefix=/usr
+ python2 waf build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ python2 waf install --destdir=$pkgdir
+}