summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPascal Ernster2020-09-26 17:26:01 +0200
committerPascal Ernster2020-09-26 17:26:01 +0200
commit75fdac73b4c97ccac26f6ef2442803281b67e3cc (patch)
treefd13f86a9b71292a4becac188694c36126f5ee6e
parente18c8333d4cf9532788350e4dd001d8d9d6d800a (diff)
downloadaur-75fdac73b4c97ccac26f6ef2442803281b67e3cc.tar.gz
libcyaml 1.1.0-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD23
2 files changed, 13 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f13c96956fd..c9734d151705 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = libcyaml
pkgdesc = C library for reading and writing YAML
- pkgver = 0.1.0
+ pkgver = 1.1.0
pkgrel = 1
url = https://github.com/tlsa/libcyaml
arch = x86_64
license = ISC
depends = libyaml
- source = https://github.com/tlsa/libcyaml/archive/v0.1.0.tar.gz
- md5sums = SKIP
+ source = https://github.com/tlsa/libcyaml/archive/v1.1.0.tar.gz
+ sha512sums = 01a328063d4bd22bf722498061af7c1b55de995bb0b84c2249b34b5708e65657767edf8f0de9a7400d09b98e5ad71f369c0cd6293710b5c9d0578276e4703643
pkgname = libcyaml
diff --git a/PKGBUILD b/PKGBUILD
index 8ae34d72409b..84ae31332bbc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,24 @@
-# Maintainer: Alexandros Theodotou <alex at zrythm dot org>
+# Contributor: Pascal Ernster <aur at hardfalcon dot net>
+# Contributor: Alexandros Theodotou <alex at zrythm dot org>
-pkgname=libcyaml
-pkgver=0.1.0
+pkgname="libcyaml"
+pkgver=1.1.0
pkgrel=1
pkgdesc="C library for reading and writing YAML"
arch=('x86_64')
url="https://github.com/tlsa/libcyaml"
license=('ISC')
depends=('libyaml')
-source=("https://github.com/tlsa/$pkgname/archive/v$pkgver.tar.gz")
-md5sums=('SKIP')
-
-prepare() {
- cd "$pkgname-$pkgver"
-}
+source=("https://github.com/tlsa/${pkgname}/archive/v${pkgver}.tar.gz")
+sha512sums=('01a328063d4bd22bf722498061af7c1b55de995bb0b84c2249b34b5708e65657767edf8f0de9a7400d09b98e5ad71f369c0cd6293710b5c9d0578276e4703643')
build() {
- cd "$pkgname-$pkgver"
+ cd "${pkgname}-${pkgver}"
make
}
package() {
- cd "$pkgname-$pkgver"
- mkdir -p $pkgdir/usr/lib/pkgconfig $pkgdir/usr/include
- make DESTDIR="$pkgdir" PREFIX=/usr install
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" PREFIX="/usr" install
+ install --target-directory="${pkgdir}/usr/share/licenses/${pkgname}" -D "LICENSE"
}