summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-01-07 08:49:26 -0600
committerLuis Martinez2022-01-07 08:49:26 -0600
commit794bb8cdf3eeccada31501ba405ab94d6e8917b3 (patch)
treecd21e2cdd77db5f6300cd205e2989e1dbef72506
parent75fdac73b4c97ccac26f6ef2442803281b67e3cc (diff)
downloadaur-794bb8cdf3eeccada31501ba405ab94d6e8917b3.tar.gz
update to 1.3.0
-rw-r--r--.SRCINFO10
-rw-r--r--CHANGES.md78
-rw-r--r--PKGBUILD33
3 files changed, 105 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9734d151705..b16c96371005 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = libcyaml
pkgdesc = C library for reading and writing YAML
- pkgver = 1.1.0
+ pkgver = 1.3.0
pkgrel = 1
url = https://github.com/tlsa/libcyaml
+ changelog = CHANGES.md
arch = x86_64
license = ISC
+ depends = glibc
depends = libyaml
- source = https://github.com/tlsa/libcyaml/archive/v1.1.0.tar.gz
- sha512sums = 01a328063d4bd22bf722498061af7c1b55de995bb0b84c2249b34b5708e65657767edf8f0de9a7400d09b98e5ad71f369c0cd6293710b5c9d0578276e4703643
+ provides = libcyaml.so
+ source = libcyaml-1.3.0.tar.gz::https://github.com/tlsa/libcyaml/archive/v1.3.0.tar.gz
+ sha512sums = c82424806d4eeac5fe3efcd9f2263ac8e0c5050dc3e4ddf044cdf0b846059812b19a67deded301bdde8da76d0f4cc92e676b338ae2fc77fe4c377f086c456edf
pkgname = libcyaml
-
diff --git a/CHANGES.md b/CHANGES.md
new file mode 100644
index 000000000000..770b70d5be00
--- /dev/null
+++ b/CHANGES.md
@@ -0,0 +1,78 @@
+LibCYAML: Change Log
+====================
+
+## LibCYAML v1.3.0
+
+* **Saving**:
+ * New flags allow control over scalar output style.
+ - For example to force single or double quote style.
+* **General**
+ * Buildsystem changes to allow use of CPPFLAGS from the environment.
+
+No changes are required for client applications to upgrade.
+
+
+## LibCYAML v1.2.1
+
+* **General**:
+ * Support for dynamic library build on Mac OS X.
+ * Ordered designated initialisers in public header for C++ compatibility.
+
+No changes are required for client applications to upgrade.
+
+
+## LibCYAML v1.2.0
+
+* **Loading**:
+ * Allow mappings with zero fields in the schema.
+ * Improved logging of errors.
+ * `CYAML_BOOL` type now treats "Off" as false.
+ * Allow loading of float values that overflow or underflow unless
+ `CYAML_FLAG_STRICT` set.
+ * Added line and column numbers to backtraces.
+* **General**:
+ * Update tests to handle libyaml 0.2.5 output format change.
+ * Buildsystem improvements.
+ * Made public header C++ compatible.
+ * Test runner supports running individual tests.
+
+No changes are required for client applications to upgrade.
+
+
+## LibCYAML v1.1.0
+
+* **Loading**:
+ * Significantly optimised handling of aliases and anchors.
+ * Fixed handling of duplicate mapping keys.
+* **Saving**:
+ * Increased precision for double precision floating point values.
+* **General**:
+ * Fixed data handling on big endian systems.
+
+No changes are required for client applications to upgrade.
+
+
+## LibCYAML v1.0.2
+
+* **Loading**:
+ * Fixed invalid read on error path for bitfield handling.
+* **Buildsystem**:
+ * Fixed to link against libraries after listing objects.
+ * Added `check` target as alias for `test`.
+
+No changes are required for client applications to upgrade.
+
+
+## LibCYAML v1.0.1
+
+* **Loading**:
+ * Fixed mapping and sequence values with `CYAML_FLAG_POINTER_NULL`.
+* **Buildsystem**:
+ * Installation: Explicitly create leading directories.
+
+No changes are required for client applications to upgrade.
+
+
+## LibCYAML v1.0.0
+
+* Initial release.
diff --git a/PKGBUILD b/PKGBUILD
index 84ae31332bbc..44f8b865021c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,33 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Pascal Ernster <aur at hardfalcon dot net>
# Contributor: Alexandros Theodotou <alex at zrythm dot org>
-pkgname="libcyaml"
-pkgver=1.1.0
+pkgname=libcyaml
+pkgver=1.3.0
pkgrel=1
-pkgdesc="C library for reading and writing YAML"
+pkgdesc='C library for reading and writing YAML'
arch=('x86_64')
-url="https://github.com/tlsa/libcyaml"
+url='https://github.com/tlsa/libcyaml'
license=('ISC')
-depends=('libyaml')
-source=("https://github.com/tlsa/${pkgname}/archive/v${pkgver}.tar.gz")
-sha512sums=('01a328063d4bd22bf722498061af7c1b55de995bb0b84c2249b34b5708e65657767edf8f0de9a7400d09b98e5ad71f369c0cd6293710b5c9d0578276e4703643')
+provides=('libcyaml.so')
+depends=('glibc' 'libyaml')
+# makedepends=('doxygen')
+changelog=CHANGES.md
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha512sums=('c82424806d4eeac5fe3efcd9f2263ac8e0c5050dc3e4ddf044cdf0b846059812b19a67deded301bdde8da76d0f4cc92e676b338ae2fc77fe4c377f086c456edf')
build() {
- cd "${pkgname}-${pkgver}"
- make
+ cd "$pkgname-$pkgver"
+ make VARIANT=release
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make test
}
package() {
- cd "${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" PREFIX="/usr" install
- install --target-directory="${pkgdir}/usr/share/licenses/${pkgname}" -D "LICENSE"
+ cd "$pkgname-$pkgver"
+ make install VARIANT=release DESTDIR="$pkgdir/" PREFIX=/usr
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}