summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraziano.giuliani2015-07-04 16:42:13 +0200
committergraziano.giuliani2015-07-04 16:42:13 +0200
commit334ebf7ae1526a281951cea6252516a7053e799b (patch)
treee5fbd25d5ae1696a758b26c9885cfcb034c82ff3
downloadaur-334ebf7ae1526a281951cea6252516a7053e799b.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6b6749034f44
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libdap
+ pkgdesc = A library which contains an implementation of DAP 2.0 and 3.1
+ pkgver = 3.14.0
+ pkgrel = 1
+ url = http://www.opendap.org/download/libdap
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ depends = curl
+ depends = libxml2
+ depends = util-linux-ng
+ source = http://www.opendap.org/pub/source/libdap-3.14.0.tar.gz
+ md5sums = 83ac4c6eb4aa8e485587de94b9757d01
+
+pkgname = libdap
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..44f3b9bc82f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+#Contributor: Nathan O <ndowens.aur at gmail dot com>
+
+pkgname=libdap
+pkgver=3.14.0
+pkgrel=1
+pkgdesc="A library which contains an implementation of DAP 2.0 and 3.1"
+arch=('i686' 'x86_64')
+url="http://www.opendap.org/download/libdap"
+license="LGPL2.1"
+depends=('curl' 'libxml2' 'util-linux-ng')
+source=(http://www.opendap.org/pub/source/${pkgname}-${pkgver}.tar.gz)
+md5sums=('83ac4c6eb4aa8e485587de94b9757d01')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ # Repeat twice: some flex generated files left around...
+ ./configure --prefix=/usr
+ make distclean
+ autoreconf --install
+ ./configure --prefix=/usr
+ make
+ make check
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
+}