summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul-Louis Ageneau2021-07-19 16:23:39 +0200
committerPaul-Louis Ageneau2021-07-19 16:23:39 +0200
commit973225f48a25fd8c7b31394e285e729356870793 (patch)
tree63271cff27c3d158e26121cd14dcf013176d8aad
parentbea788b05b208b8a2ad476b1daebd4ec76a9d480 (diff)
downloadaur-973225f48a25fd8c7b31394e285e729356870793.tar.gz
Bumped version to v0.14.0, use external libjuice, and use CMake to install
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD22
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aaebb3adf543..608b3aec532e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libdatachannel
pkgdesc = C/C++ WebRTC Data Channels and Media Transport lightweight library
- pkgver = v0.13.5
+ pkgver = 0.14.0
pkgrel = 1
url = https://github.com/paullouisageneau/libdatachannel
arch = x86_64
@@ -8,10 +8,11 @@ pkgbase = libdatachannel
makedepends = git
makedepends = cmake
depends = openssl
+ depends = libjuice
depends = libsrtp
provides = libdatachannel
conflicts = libdatachannel
- source = git+https://github.com/paullouisageneau/libdatachannel.git#tag=v0.13.5
+ source = git+https://github.com/paullouisageneau/libdatachannel.git#tag=v0.14.0
md5sums = SKIP
pkgname = libdatachannel
diff --git a/PKGBUILD b/PKGBUILD
index ae807ee07829..6daa8d9bd73e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,37 +2,35 @@
# Maintainer: Paul-Louis Ageneau <paul-louis at ageneau dot org>
pkgname=libdatachannel
-pkgver=v0.13.5
+pkgver=0.14.0
pkgrel=1
pkgdesc="C/C++ WebRTC Data Channels and Media Transport lightweight library"
arch=('x86_64')
url="https://github.com/paullouisageneau/$pkgname"
license=('LGPL')
makedepends=('git' 'cmake')
-depends=('openssl' 'libsrtp')
+depends=('openssl' 'libjuice' 'libsrtp')
provides=("$pkgname")
conflicts=("$pkgname")
-source=("git+https://github.com/paullouisageneau/$pkgname.git#tag=$pkgver")
+source=("git+https://github.com/paullouisageneau/$pkgname.git#tag=v$pkgver")
md5sums=('SKIP')
prepare() {
- cd "$pkgname"
- git submodule update --init --recursive "$srcdir"/"$pkgname"/deps/{libsrtp,usrsctp,plog,libjuice}
+ cd $pkgname
+ git submodule update --init --recursive "$srcdir"/"$pkgname"/deps/{libsrtp,usrsctp,plog}
}
build() {
- cd "$pkgname"
+ cd $pkgname
rm -rf build
- cmake -B build -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DUSE_NICE=0 -DUSE_GNUTLS=0 -DUSE_SYSTEM_SRTP=1 -DNO_TESTS=1 -DNO_EXAMPLES=1
+ cmake -B build -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DUSE_GNUTLS=0 -DUSE_NICE=0 -DUSE_SYSTEM_JUICE=1 -DUSE_SYSTEM_SRTP=1 -DNO_TESTS=1 -DNO_EXAMPLES=1
cd build
make
}
package() {
- cd "$pkgname"
- install -m755 -d "$pkgdir"/usr/include/rtc
- install -m644 include/rtc/*.{hpp,h} "$pkgdir"/usr/include/rtc
- install -m755 -d "$pkgdir"/usr/lib
- install -m755 build/"$pkgname".so "$pkgdir"/usr/lib
+ cd $pkgname
+ cd build
+ make DESTDIR="$pkgdir/" install
}