summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul-Louis Ageneau2021-04-09 19:29:25 +0200
committerPaul-Louis Ageneau2021-04-09 19:29:25 +0200
commitc0d3097fc972531935a2f8606c4420b56744be52 (patch)
tree997aac7a73081eeaff0d56d2158651b75f4913f1
parent422ab9eff9cb937e0fd2a748c8d2bb88314388f4 (diff)
downloadaur-c0d3097fc972531935a2f8606c4420b56744be52.tar.gz
Added dependency on plog rather than installing it
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index afd07d22133b..ebad2912250b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,6 +9,7 @@ pkgbase = libdatachannel
makedepends = cmake
depends = openssl
depends = libsrtp
+ depends = plog
provides = libdatachannel
conflicts = libdatachannel
source = git+https://github.com/paullouisageneau/libdatachannel.git#tag=v0.12.1
diff --git a/PKGBUILD b/PKGBUILD
index e83eca163715..83292febd4e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ arch=('x86_64')
url="https://github.com/paullouisageneau/$pkgname"
license=('LGPL')
makedepends=('git' 'cmake')
-depends=('openssl' 'libsrtp')
+depends=('openssl' 'libsrtp', 'plog')
provides=("$pkgname")
conflicts=("$pkgname")
source=("git+https://github.com/paullouisageneau/$pkgname.git#tag=$pkgver")
@@ -31,6 +31,8 @@ build() {
package() {
cd "$pkgname"
- cd build
- make DESTDIR="$pkgdir/" install
+ install -m755 -d "$pkgdir"/usr/include/"$pkgname"
+ install -m644 include/rtc/*.{hpp,h} "$pkgdir"/usr/include/"$pkgname"
+ install -m755 -d "$pkgdir"/usr/lib
+ install -m755 build/"$pkgname".so "$pkgdir"/usr/lib
}