summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-08-12 16:21:56 +0800
committerChocobo12017-08-12 16:25:24 +0800
commit937199547543637c06597052117fd08d6cf6fe0d (patch)
treec2a14dcb8a42ed8a51f55f27f208e4ec69dce73d
downloadaur-937199547543637c06597052117fd08d6cf6fe0d.tar.gz
newpkg: libdca-git 1:76c67bc-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..decbb0f116e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libdca-git
+ pkgdesc = A library for decoding DTS Coherent Acoustics streams
+ pkgver = 76c67bc
+ pkgrel = 1
+ epoch = 1
+ url = https://www.videolan.org/developers/libdca.html
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = glibc
+ provides = libdca
+ conflicts = libdca
+ source = git+https://code.videolan.org/videolan/libdca.git
+ sha256sums = SKIP
+
+pkgname = libdca-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a1642131f202
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libdca-git
+pkgver=76c67bc
+pkgrel=1
+epoch=1
+pkgdesc="A library for decoding DTS Coherent Acoustics streams"
+arch=('i686' 'x86_64')
+url="https://www.videolan.org/developers/libdca.html"
+license=('GPL2')
+depends=('glibc')
+makedepends=('git')
+provides=('libdca')
+conflicts=('libdca')
+source=("git+https://code.videolan.org/videolan/libdca.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "libdca"
+
+ git describe --always
+}
+
+build() {
+ cd "libdca"
+
+ ./bootstrap
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "libdca"
+
+ make check
+}
+
+package() {
+ cd "libdca"
+
+ make DESTDIR="$pkgdir" install
+}