summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGötz2024-03-02 18:34:28 -0500
committerGötz2024-03-02 18:36:30 -0500
commitcee3ad505af17060885f64c60585da1e09b10ecf (patch)
tree270c4aaa65ce220686bf912a44fa965f10adb5f0
downloadaur-cee3ad505af17060885f64c60585da1e09b10ecf.tar.gz
New package using version 3.6.7
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore3
-rw-r--r--Makefile56
-rw-r--r--PKGBUILD32
4 files changed, 112 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0a1c1f929953
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = libdcmtk17-bin
+ pkgdesc = OFFIS DICOM toolkit runtime libraries.
+ pkgver = 3.6.7
+ pkgrel = 1
+ url = https://dicom.offis.de/dcmtk
+ arch = i686
+ arch = x86_64
+ depends = libpng>=1.6.2
+ depends = libtiff>=4.0.3
+ depends = libwrap>=7.6
+ depends = libxml2>=2.7.4
+ depends = openssl>=3.0
+ depends = zlib>=1.1.4
+ provides = libdcmtk17
+ replaces = libdcmtk17
+ options = !strip
+ options = !emptydirs
+ source_x86_64 = https://mirrors.kernel.org/ubuntu/pool/universe/d/dcmtk/libdcmtk17_3.6.7-9_amd64.deb
+ sha256sums_x86_64 = 92ecfa3cd190b1305d3cca8f8316c9942f1a1dec00c84315e8cac87fe26afccd
+
+pkgname = libdcmtk17-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e82d15a5f7de
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/pkg/
+/src/
+libdcmtk17*
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..a3d7fbe7b41d
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,56 @@
+.SHELL = /usr/bin/env bash
+
+NAME = "$(shell grep -m 1 pkgname .SRCINFO | cut -d '=' -f 2 | xargs)"
+URL = "$(shell grep url .SRCINFO | cut -d '=' -f 2 | xargs)"
+VERSION = "$(shell grep pkgver .SRCINFO | cut -d '=' -f 2 | xargs)"
+
+.PHONY: all
+all: build git install
+
+.PHONY: clean
+clean:
+ rm -r src pkg || true
+
+.PHONY: geninteg
+geninteg:
+ sed -i '/.*sums.*=(/,$$d' PKGBUILD
+ makepkg --geninteg >> PKGBUILD
+
+.PHONY: srcinfo
+srcinfo:
+ makepkg --printsrcinfo > .SRCINFO
+
+.PHONY: makepkg
+makepkg:
+ makepkg --syncdeps --force
+
+.PHONY: build
+build: geninteg srcinfo makepkg
+
+.PHONY: git
+git: git_add git_commit
+
+.PHONY: git_add
+git_add:
+ git add PKGBUILD .SRCINFO Makefile
+
+.PHONY: git_commit
+git_commit: GIT_STATUS = "$(shell git status --porcelain)"
+git_commit:
+ [ -n ${GIT_STATUS} ] && git commit -m "Update to ${VERSION}"
+
+.PHONY: install
+install:
+ makepkg --repackage --install --force
+
+.PHONY: open
+open:
+ xdg-open $(URL)
+
+.PHONY: run
+run:
+ env $(NAME)
+
+.PHONY: test
+test:
+ env $(NAME) --version
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dbfb6a5d3194
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+pkgname=libdcmtk17-bin
+_pkgname="${pkgname%-*}"
+pkgver=3.6.7
+pkgrel=1
+_debrel=9
+pkgdesc="OFFIS DICOM toolkit runtime libraries."
+arch=('i686' 'x86_64')
+url="https://dicom.offis.de/dcmtk"
+_url="https://packages.ubuntu.com/noble/libdcmtk17" # LTS
+provides=("${_pkgname}")
+replaces=("${_pkgname}")
+depends=(
+ 'libpng>=1.6.2'
+ 'libtiff>=4.0.3'
+ 'libwrap>=7.6'
+ 'libxml2>=2.7.4'
+ 'openssl>=3.0'
+ 'zlib>=1.1.4'
+)
+options=('!strip' '!emptydirs')
+
+source_x86_64=("https://mirrors.kernel.org/ubuntu/pool/universe/d/dcmtk/${_pkgname}_${pkgver}-${_debrel}_amd64.deb")
+
+package() {
+ tar xf data.tar.zst -C "${pkgdir}"
+ find "${pkgdir}/usr/lib/x86_64-linux-gnu/" -type f,l | xargs -I{} mv {} "${pkgdir}/usr/lib/"
+ rmdir "${pkgdir}/usr/lib/x86_64-linux-gnu/"
+
+ install -D -m644 "${pkgdir}/usr/share/doc/${_pkgname}/copyright" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}
+
+sha256sums_x86_64=('92ecfa3cd190b1305d3cca8f8316c9942f1a1dec00c84315e8cac87fe26afccd')