summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Kalb2015-06-16 13:59:45 +0200
committerMarkus Kalb2015-06-16 13:59:45 +0200
commit1e3463b793022b13ff4e8120d15d60db9a1a3d71 (patch)
tree62a12a1b38cfd031587053da21d33d9f8fedd31c
parentb41b2c6bb4b9a87876283de150af7811f64e3487 (diff)
downloadaur-1e3463b793022b13ff4e8120d15d60db9a1a3d71.tar.gz
PKGBUILD updates for aur4 Arch packaging standards
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 2 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc2c66de085e..6a96bd7380cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libdcp
pkgdesc = A small C++ library which can create and read Digital Cinema Packages using JPEG2000 and WAV files
pkgver = 0.101.0
- pkgrel = 3
+ pkgrel = 4
url = http://carlh.net/software/libdcp
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 06ef74b038b1..6137b49ef0be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,35 +2,24 @@
# Contributor: Stefan Karner <stefan.karner@student.tuwien.ac.at>
pkgname=libdcp
pkgver=0.101.0
-pkgrel=3
+pkgrel=4
pkgdesc="A small C++ library which can create and read Digital Cinema Packages using JPEG2000 and WAV files"
arch=('i686' 'x86_64')
url="http://carlh.net/software/libdcp"
license=('GPL')
-groups=
depends=('openssl' 'libxml++>=2.6' 'xmlsec' 'openjpeg' 'libcxml>=0.11.0' 'libsigc++>=2.0' 'boost-libs>=1.45')
makedepends=('python2' 'boost>=1.45')
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
source=("http://carlh.net/downloads/${pkgname}/${pkgname}-${pkgver}.tar.bz2")
sha256sums=('94ff6fa5d478a0c327589fdca999c6bc4c7d74405d07c90f7cd27e7c8fe8c68e')
-
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
-
python2 waf configure --prefix=/usr
python2 waf build
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
-
python2 waf install --destdir=$pkgdir
}