summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Kalb2015-07-28 16:07:49 +0200
committerMarkus Kalb2015-07-28 16:07:49 +0200
commit4bb0fdad57a32be0e9aeb1198086109a3f8ae474 (patch)
tree29b54ab5a5532d67b31e345a6a05629b30a2bf11
parent1e3463b793022b13ff4e8120d15d60db9a1a3d71 (diff)
downloadaur-4bb0fdad57a32be0e9aeb1198086109a3f8ae474.tar.gz
libdcp-1.1.0 with working patch
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
-rw-r--r--libdcp-1.1.0-arch-mk1.patch23
3 files changed, 44 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a96bd7380cb..4490724b6ffa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libdcp
pkgdesc = A small C++ library which can create and read Digital Cinema Packages using JPEG2000 and WAV files
- pkgver = 0.101.0
- pkgrel = 4
+ pkgver = 1.1.0
+ pkgrel = 1
url = http://carlh.net/software/libdcp
arch = i686
arch = x86_64
@@ -12,11 +12,13 @@ pkgbase = libdcp
depends = libxml++>=2.6
depends = xmlsec
depends = openjpeg
- depends = libcxml>=0.11.0
+ depends = libcxml>=0.12.0
depends = libsigc++>=2.0
depends = boost-libs>=1.45
- source = http://carlh.net/downloads/libdcp/libdcp-0.101.0.tar.bz2
- sha256sums = 94ff6fa5d478a0c327589fdca999c6bc4c7d74405d07c90f7cd27e7c8fe8c68e
+ source = http://carlh.net/downloads/libdcp/libdcp-1.1.0.tar.bz2
+ source = libdcp-1.1.0-arch-mk1.patch
+ sha256sums = 646f98666f427900dee58d48440e3c8fb440e11158b92dccacd1b9885a1561a2
+ sha256sums = 61fae76f13c39807781c02c719a0934ee290cf507baefd9ce0b161a4fbc3a716
pkgname = libdcp
diff --git a/PKGBUILD b/PKGBUILD
index 6137b49ef0be..0958363b82aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,25 @@
# Maintainer: Markus Kalb <mk@filmkreis.tu-darmstadt.de>
# Contributor: Stefan Karner <stefan.karner@student.tuwien.ac.at>
pkgname=libdcp
-pkgver=0.101.0
-pkgrel=4
+pkgver=1.1.0
+pkgrel=1
pkgdesc="A small C++ library which can create and read Digital Cinema Packages using JPEG2000 and WAV files"
arch=('i686' 'x86_64')
url="http://carlh.net/software/libdcp"
license=('GPL')
-depends=('openssl' 'libxml++>=2.6' 'xmlsec' 'openjpeg' 'libcxml>=0.11.0' 'libsigc++>=2.0' 'boost-libs>=1.45')
+depends=('openssl' 'libxml++>=2.6' 'xmlsec' 'openjpeg' 'libcxml>=0.12.0' 'libsigc++>=2.0' 'boost-libs>=1.45')
makedepends=('python2' 'boost>=1.45')
-source=("http://carlh.net/downloads/${pkgname}/${pkgname}-${pkgver}.tar.bz2")
-sha256sums=('94ff6fa5d478a0c327589fdca999c6bc4c7d74405d07c90f7cd27e7c8fe8c68e')
+source=("http://carlh.net/downloads/${pkgname}/${pkgname}-${pkgver}.tar.bz2" "libdcp-1.1.0-arch-mk1.patch")
+sha256sums=('646f98666f427900dee58d48440e3c8fb440e11158b92dccacd1b9885a1561a2'
+ '61fae76f13c39807781c02c719a0934ee290cf507baefd9ce0b161a4fbc3a716')
+
+
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p1 -i "${srcdir}/libdcp-1.1.0-arch-mk1.patch"
+}
+
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
diff --git a/libdcp-1.1.0-arch-mk1.patch b/libdcp-1.1.0-arch-mk1.patch
new file mode 100644
index 000000000000..e5094fee90c9
--- /dev/null
+++ b/libdcp-1.1.0-arch-mk1.patch
@@ -0,0 +1,23 @@
+diff -aur libdcp-1.1.0.pristine/src/reel_asset.cc libdcp-1.1.0.new/src/reel_asset.cc
+--- libdcp-1.1.0.pristine/src/reel_asset.cc 2015-06-13 16:21:05.000000000 +0200
++++ libdcp-1.1.0.new/src/reel_asset.cc 2015-07-28 15:01:39.744519973 +0200
+@@ -27,6 +27,8 @@
+ #include "compose.hpp"
+ #include <libcxml/cxml.h>
+ #include <libxml++/libxml++.h>
++#include <iostream>
++
+
+ using std::pair;
+ using std::cout;
+diff -aur libdcp-1.1.0.pristine/test/read_smpte_subtitle_test.cc libdcp-1.1.0.new/test/read_smpte_subtitle_test.cc
+--- libdcp-1.1.0.pristine/test/read_smpte_subtitle_test.cc 2015-06-13 16:21:05.000000000 +0200
++++ libdcp-1.1.0.new/test/read_smpte_subtitle_test.cc 2015-07-28 15:28:20.814658043 +0200
+@@ -22,6 +22,7 @@
+ #include "local_time.h"
+ #include "smpte_load_font_node.h"
+ #include <boost/test/unit_test.hpp>
++#include <boost/optional/optional_io.hpp>
+
+ using std::list;
+ using boost::shared_ptr;