summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Kalb2015-06-16 13:59:59 +0200
committerMarkus Kalb2015-06-16 13:59:59 +0200
commitbc0c72484efa537ee6cd52d0f8f0f330c84d35e8 (patch)
treebdce3bb8db018a1f88477033dffb6ebbbc1ddb83
parentd3949899c5848bd21eb76ba6c7cce2dbe280c77d (diff)
downloadaur-bc0c72484efa537ee6cd52d0f8f0f330c84d35e8.tar.gz
PKGBUILD updates for aur4 Arch packaging standards
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD20
2 files changed, 6 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fda1d29954a8..a4faefe54efa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libdcp-git
pkgdesc = A small C++ library which can create and read Digital Cinema Packages using JPEG2000 and WAV files
pkgver = 0.r808.bbb3db1
- pkgrel = 2
+ pkgrel = 3
url = http://carlh.net/software/libdcp
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 962452c0934a..5bea9592a664 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,42 +2,32 @@
# Contributor: Stefan Karner <stefan.karner@student.tuwien.ac.at>
pkgname=libdcp-git
pkgver=0.r808.bbb3db1
-pkgrel=2
+pkgrel=3
pkgdesc="A small C++ library which can create and read Digital Cinema Packages using JPEG2000 and WAV files"
arch=('i686' 'x86_64')
url="http://carlh.net/software/libdcp"
license=('GPL')
-groups=
depends=('openssl' 'libxml++>=2.6' 'xmlsec' 'openjpeg' 'libcxml-git' 'libsigc++>=2.0' 'boost-libs>=1.45')
makedepends=('python2' 'boost>=1.45')
-optdepends=()
provides=('libdcp')
conflicts=('libdcp')
-replaces=()
-backup=()
-options=()
-install=
source=("libdcp-git::git+http://git.carlh.net/git/libdcp.git")
-
-# git variables
-_gitname='libdcp-git'
+sha512sums=('SKIP')
pkgver() {
- cd "$_gitname"
-
+ cd libdcp-git
printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$_gitname"
+ cd libdcp-git
python2 waf configure --prefix=/usr
python2 waf build
}
package() {
- cd "$_gitname"
+ cd libdcp-git
python2 waf install --destdir=$pkgdir
}
-sha512sums=('SKIP')