summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2018-02-22 22:39:17 -0500
committerGuillaume Horel2018-02-22 22:39:17 -0500
commit82792d6a1c944a8b0ed21361d36ee4266fb605c4 (patch)
treefb1a16a3553c26f365c8da8a857e0a48be31b027
downloadaur-82792d6a1c944a8b0ed21361d36ee4266fb605c4.tar.gz
initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b47e8270f635
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = libdecaf
+ pkgdesc = A 448-bit Edwards curve
+ pkgver = 0.9.4
+ pkgrel = 1
+ url = https://sourceforge.net/projects/ed448goldilocks/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ source = https://sourceforge.net/projects/ed448goldilocks/files/libdecaf-0.9.4.tgz
+ sha256sums = 6b0b6dc77a8dec88ea5b45902f8211d9f6c55b3346191dcd0aaeeb45a8d23f7f
+
+pkgname = libdecaf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..396a19022309
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgbase=('libdecaf')
+pkgname=('libdecaf')
+pkgver='0.9.4'
+pkgrel=1
+pkgdesc="A 448-bit Edwards curve"
+url="https://sourceforge.net/projects/ed448goldilocks/"
+depends=()
+makedepends=()
+license=('MIT')
+arch=('i686' 'x86_64')
+source=("https://sourceforge.net/projects/ed448goldilocks/files/$pkgname-$pkgver.tgz")
+sha256sums=('6b0b6dc77a8dec88ea5b45902f8211d9f6c55b3346191dcd0aaeeb45a8d23f7f')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make lib
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -D build/lib/libdecaf.so.1 "${pkgdir}/usr/lib/libdecaf.so.1"
+ ln -sr ${pkgdir}/usr/lib/libdecaf.so{.1,}
+ install -d "${pkgdir}/usr/include/decaf"
+ install -D -m644 src/GENERATED/include/decaf/*.{h,hxx} "${pkgdir}/usr/include/decaf/"
+ install -D -m644 src/GENERATED/include/*.{h,hxx} "${pkgdir}/usr/include"
+}