summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Wilken2020-05-02 17:25:34 +0100
committerTimo Wilken2020-05-02 17:25:34 +0100
commit62f8d9ebbbe5d832ba9d9c723c1837f656111ca3 (patch)
tree5285a729d9e390f60f7b2fb559f149b551cbca62
downloadaur-62f8d9ebbbe5d832ba9d9c723c1837f656111ca3.tar.gz
Initial commit; upstream version 1.3.0.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..972bc1eeffa5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = libdecsync
+ pkgdesc = libdecsync is a multiplatform library for synchronizing using DecSync.
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://github.com/39aldo39/libdecsync
+ arch = x86_64
+ license = LGPL2
+ makedepends = jdk8-openjdk
+ makedepends = ncurses5-compat-libs
+ source = libdecsync-1.3.0.tar.gz::https://github.com/39aldo39/libdecsync/archive/v1.3.0.tar.gz
+ sha256sums = e3c0cda44c2ce25824c4d8ad62432073b44a77efce10b1454b8ba53b3b52da0c
+
+pkgname = libdecsync
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd2b3592a1a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Timo Wilken <timo.21.wilken+aur@gmail.com>
+pkgname=libdecsync
+pkgver=1.3.0
+pkgrel=1
+pkgdesc='libdecsync is a multiplatform library for synchronizing using DecSync.'
+arch=(x86_64)
+url='https://github.com/39aldo39/libdecsync'
+license=(LGPL2)
+depends=()
+optdepends=()
+makedepends=(jdk8-openjdk ncurses5-compat-libs)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/39aldo39/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('e3c0cda44c2ce25824c4d8ad62432073b44a77efce10b1454b8ba53b3b52da0c')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ # For some reason, make exits with status 2 even if the build succeeded.
+ make || :
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}