summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Wilken2021-08-03 00:22:10 +0200
committerTimo Wilken2021-08-03 00:22:10 +0200
commitf27b8360e762d3a79c64b79fdd72ec263f7c1264 (patch)
treeb91e81aebc92f4d4b9e699c946fc6c6b3f72b221
parent01b1fce61784814d564b0f6136108121a4e47cb9 (diff)
downloadaur-f27b8360e762d3a79c64b79fdd72ec263f7c1264.tar.gz
Use JDK8 specifically
Java and ncurses also only seem to be makedeps (needed for gradle, but for libdecsync itself). We need jre8-openjdk specifically to build, other jre*-openjdk won't work.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e770da924af..b6cf25951507 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = libdecsync
pkgdesc = libdecsync is a multiplatform library for synchronizing using DecSync.
pkgver = 1.9.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/39aldo39/libdecsync
arch = x86_64
license = LGPL2
- depends = java-runtime-openjdk
- depends = ncurses5-compat-libs
+ makedepends = jre8-openjdk
+ makedepends = ncurses5-compat-libs
source = libdecsync-1.9.0.tar.gz::https://github.com/39aldo39/libdecsync/archive/v1.9.0.tar.gz
sha256sums = 6e1f0dc5fa0917d12943b07984248b045af45ff8f63096c4ccfe9deac7782f32
pkgname = libdecsync
-
diff --git a/PKGBUILD b/PKGBUILD
index f95857c36e17..2554a5a5d26c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer: Timo Wilken <timo.21.wilken+aur@gmail.com>
pkgname=libdecsync
pkgver=1.9.0
-pkgrel=1
+pkgrel=2
pkgdesc='libdecsync is a multiplatform library for synchronizing using DecSync.'
arch=(x86_64)
url='https://github.com/39aldo39/libdecsync'
license=(LGPL2)
-depends=(java-runtime-openjdk ncurses5-compat-libs)
+depends=()
optdepends=()
-makedepends=()
+makedepends=(jre8-openjdk ncurses5-compat-libs)
source=("$pkgname-$pkgver.tar.gz::https://github.com/39aldo39/$pkgname/archive/v$pkgver.tar.gz")
sha256sums=('6e1f0dc5fa0917d12943b07984248b045af45ff8f63096c4ccfe9deac7782f32')
build() {
cd "$srcdir/$pkgname-$pkgver"
# For some reason, make exits with status 2 even if the build succeeded.
- make || :
+ env -u _JAVA_OPTIONS JAVA_HOME=/usr/lib/jvm/java-8-openjdk/jre make || :
}
package() {