summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Bruhin2018-09-10 16:37:14 +0200
committerFlorian Bruhin2018-09-10 16:37:14 +0200
commitf13522fe4dc63a82dfc6a5f82b93cc64a91c07c2 (patch)
tree2e72e5d523671b3995ac118179e148698cefb431
downloadaur-f13522fe4dc63a82dfc6a5f82b93cc64a91c07c2.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD30
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..00b88a28496e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Mon Sep 10 14:37:08 UTC 2018
+pkgbase = libdeltachat-core-git
+ pkgdesc = Library that provides the core functionality needed by the different user interfaces of deltachat.
+ pkgver = v0.20.0.r82.g1d11566a
+ pkgrel = 1
+ url = https://github.com/deltachat/deltachat-core
+ arch = x86_64
+ license = GPL
+ makedepends = meson
+ depends = openssl
+ depends = sqlite
+ depends = libsasl
+ depends = zlib
+ depends = bzip2
+ options = debug
+ options = !strip
+ source = git+https://github.com/deltachat/deltachat-core.git
+ sha1sums = SKIP
+
+pkgname = libdeltachat-core-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c709d4e9f3c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Florian Bruhin (The Compiler) <archlinux.org@the-compiler.org>
+
+pkgname=libdeltachat-core-git
+pkgver=v0.20.0.r82.g1d11566a
+pkgrel=1
+pkgdesc="Library that provides the core functionality needed by the different user interfaces of deltachat."
+arch=(x86_64)
+url="https://github.com/deltachat/deltachat-core"
+license=('GPL')
+#depends=('libetpan' 'openssl' 'sqlite' 'libsasl' 'zlib' 'bzip2')
+depends=('openssl' 'sqlite' 'libsasl' 'zlib' 'bzip2')
+makedepends=('meson')
+source=(git+https://github.com/deltachat/deltachat-core.git)
+sha1sums=('SKIP')
+options=('debug' '!strip')
+
+pkgver() {
+ cd deltachat-core
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+#meson --prefix /usr --buildtype=plain -Dsystem-etpan=true deltachat-core build
+ meson --prefix /usr --buildtype=plain deltachat-core build
+ ninja -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+}