summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-07-08 21:47:42 -0600
committerBrian Bidulock2015-07-08 21:47:42 -0600
commit32dc66e5e291fb3333db5fd08b5099a3f01ecf8e (patch)
tree66151ca221dc2f7cbbbe11cf10789c34f02b58a5
downloadaur-32dc66e5e291fb3333db5fd08b5099a3f01ecf8e.tar.gz
initial version
-rw-r--r--.SRCINFO27
-rw-r--r--ListStore.patch56
-rw-r--r--PKGBUILD46
-rw-r--r--megalo.patch105
4 files changed, 234 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..50868cc2a165
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = libdesktop-agnostic
+ pkgdesc = Provides an extensible config API, a unified virtual fs API, and a desktop item editor for GLib-based projects
+ pkgver = 0.3.92
+ pkgrel = 8
+ url = https://launchpad.net/libdesktop-agnostic
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ makedepends = intltool
+ makedepends = vala
+ makedepends = gconf
+ makedepends = gobject-introspection
+ depends = pygtk
+ optdepends = gconf: gconf configuration backend
+ options = !libtool
+ options = !strip
+ backup = etc/xdg/libdesktop-agnostic/desktop-agnostic.ini
+ source = https://launchpad.net/libdesktop-agnostic/0.4/0.3.92/+download/libdesktop-agnostic-0.3.92.tar.gz
+ source = megalo.patch
+ source = ListStore.patch
+ md5sums = 42374d226a21d57637f97173f6b105a1
+ md5sums = 9be8f4e706b933f456393a782d89d555
+ md5sums = fc0d00e48be5be46045307b4366408be
+
+pkgname = libdesktop-agnostic
+
diff --git a/ListStore.patch b/ListStore.patch
new file mode 100644
index 000000000000..5316dc719eba
--- /dev/null
+++ b/ListStore.patch
@@ -0,0 +1,56 @@
+diff --git a/libdesktop-agnostic/ui-icon-chooser-dialog.vala b/libdesktop-agnostic/ui-icon-chooser-dialog.vala
+index 604c976..8e065f5 100644
+--- libdesktop-agnostic.bak/ui-icon-chooser-dialog.vala
++++ libdesktop-agnostic/ui-icon-chooser-dialog.vala
+@@ -165,7 +165,7 @@ namespace DesktopAgnostic.UI
+ {
+ TreeIter iter;
+ Value val;
+- var store = this._viewer.model as ListStore;
++ var store = this._viewer.model as Gtk.ListStore;
+ store.get_iter (out iter, p);
+ store.get_value (iter, Column.DATA, out val);
+
+@@ -205,11 +205,11 @@ namespace DesktopAgnostic.UI
+ return viewer;
+ }
+
+- private ListStore
++ private Gtk.ListStore
+ create_model ()
+ {
+ // icon, name, data
+- return new ListStore (Column.COUNT,
++ return new Gtk.ListStore (Column.COUNT,
+ typeof (Gdk.Pixbuf),
+ typeof (string),
+ typeof (string),
+@@ -291,12 +291,12 @@ namespace DesktopAgnostic.UI
+ private void
+ on_folder_changed (FileChooser chooser)
+ {
+- unowned ListStore model;
++ unowned Gtk.ListStore model;
+ string uri;
+ VFS.File directory;
+ SList<VFS.File> children;
+
+- model = this._file_viewer.model as ListStore;
++ model = this._file_viewer.model as Gtk.ListStore;
+ model.clear ();
+
+ uri = chooser.get_uri ();
+@@ -342,11 +342,11 @@ namespace DesktopAgnostic.UI
+ private void
+ on_icon_context_changed (ComboBox box)
+ {
+- unowned ListStore model;
++ unowned Gtk.ListStore model;
+ unowned IconTheme icon_theme;
+ List<string> icon_list;
+
+- model = this._themed_viewer.model as ListStore;
++ model = this._themed_viewer.model as Gtk.ListStore;
+ model.clear ();
+
+ icon_theme = IconTheme.get_default ();
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42081c1331ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer:
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+# Contributor: Jan "heftig" Steffens <jan.steffens@gmail.com>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+# Contributor: Leo von Klenze <leo@von-klenze.de>
+
+pkgname=libdesktop-agnostic
+pkgver=0.3.92
+pkgrel=8
+pkgdesc='Provides an extensible config API, a unified virtual fs API, and a desktop item editor for GLib-based projects'
+arch=('i686' 'x86_64')
+url='https://launchpad.net/libdesktop-agnostic'
+license=('GPL' 'LGPL')
+depends=('pygtk')
+makedepends=('intltool' 'vala' 'gconf' 'gobject-introspection')
+optdepends=('gconf: gconf configuration backend')
+options=('!libtool' '!strip')
+backup=(etc/xdg/libdesktop-agnostic/desktop-agnostic.ini)
+source=("https://launchpad.net/$pkgname/0.4/$pkgver/+download/$pkgname-$pkgver.tar.gz" megalo.patch ListStore.patch)
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ [ -d build ] && rm -R build
+ [ -d gen_src ] && rm -R gen_src
+
+ patch -Np0 -i ../megalo.patch
+ patch -Np0 -i ../ListStore.patch
+
+ export PYTHON=/usr/bin/python2
+ python2 ./waf configure --prefix=/usr --sysconfdir=/etc \
+ --config-backends=gconf,keyfile \
+ --vfs-backends=gio \
+ --desktop-entry-backends=gio,glib
+ python2 ./waf
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ python2 ./waf install --destdir="$pkgdir"
+}
+
+md5sums=('42374d226a21d57637f97173f6b105a1'
+ '9be8f4e706b933f456393a782d89d555'
+ 'fc0d00e48be5be46045307b4366408be')
diff --git a/megalo.patch b/megalo.patch
new file mode 100644
index 000000000000..572536025244
--- /dev/null
+++ b/megalo.patch
@@ -0,0 +1,105 @@
+# Fixs segfault in AWN when Schema.get_metadata_option returns something, that
+# is not boolean
+--- libdesktop-agnostic.bak/config-client.vala 2011-03-12 15:14:23.000000000 +0100
++++ libdesktop-agnostic/config-client.vala 2013-10-28 01:01:10.894005264 +0100
+@@ -134,7 +134,7 @@
+ create_instance_config (string instance_id) throws GLib.Error
+ {
+- Value single_instance = this._schema.get_metadata_option ("single_instance");
+- if ((bool)single_instance)
++ Value? single_instance = this._schema.get_metadata_option ("single_instance");
++ if ((single_instance != null) && (single_instance.get_boolean()) )
+ {
+ return false;
+ }
+# ParamSpecEnum disappeared from gobject
+diff -ur libdesktop-agnostic.bak/config-bridge.vala libdesktop-agnostic/config-bridge.vala
+--- libdesktop-agnostic.bak/config-bridge.vala 2011-03-12 15:14:23.000000000 +0100
++++ libdesktop-agnostic/config-bridge.vala 2013-10-28 00:21:12.524020208 +0100
+@@ -216,7 +216,7 @@
+ spec.value_type == typeof (double) ||
+ spec.value_type == typeof (int) ||
+ spec.value_type == typeof (long) ||
+- spec is ParamSpecEnum ||
++ // spec is ParamSpecEnum ||
+ spec.value_type == typeof (string))
+ {
+ func (config, group, key, notifier.on_simple_value_changed);
+# Probably bug in vala compiler, generated c-code accessed non-existing field on NotifyDelegate.
+diff -ur libdesktop-agnostic.bak/config-impl-keyfile.vala libdesktop-agnostic/config-impl-keyfile.vala
+--- libdesktop-agnostic.bak/config-impl-keyfile.vala 2011-03-12 15:14:23.000000000 +0100
++++ libdesktop-agnostic/config-impl-keyfile.vala 2013-10-28 00:49:46.827342860 +0100
+@@ -423,10 +423,8 @@
+ unowned SList<NotifyDelegate> funcs = this._notifiers.get_data (full_key);
+ foreach (unowned NotifyDelegate data in funcs)
+ {
+- if (data != null && data.callback != null)
+- {
++ // Modified according to config-impl-gconf.vala
+ data.execute (group, key, value);
+- }
+ }
+ }
+
+# Updated to current GLib bindigs
+diff -ur libdesktop-agnostic.bak/vfs-file-impl-gio.vala libdesktop-agnostic/vfs-file-impl-gio.vala
+--- libdesktop-agnostic.bak/vfs-file-impl-gio.vala 2011-03-12 15:14:23.000000000 +0100
++++ libdesktop-agnostic/vfs-file-impl-gio.vala 2013-10-28 00:12:29.530690133 +0100
+@@ -177,13 +177,21 @@
+ public override bool
+ load_contents (out string contents, out size_t length) throws Error
+ {
+- return this._file.load_contents (null, out contents, out length, null);
++ uint8 [] glib_contents;
++ string etag_out;
++ if (this._file.load_contents (null, out glib_contents, out etag_out)) {
++ contents = (string)glib_contents;
++ length = glib_contents.length;
++ g_free(glib_contents);
++ return true;
++ } else {
++ return false;
++ }
+ }
+ public override bool
+ replace_contents (string contents) throws Error
+ {
+- return this._file.replace_contents (contents, contents.size (), null,
+- false, 0, null, null);
++ return this._file.replace_contents ((uint8[])contents, null, false, FileCreateFlags.NONE, null);
+ }
+ public override bool
+ launch () throws Error
+# Return value transfers ownership but method return type hasn't been declared to
+# transfer ownership
+diff -ur libdesktop-agnostic.bak/vfs-volume-impl-gio.vala libdesktop-agnostic/vfs-volume-impl-gio.vala
+--- libdesktop-agnostic.bak/vfs-volume-impl-gio.vala 2011-03-12 15:14:23.000000000 +0100
++++ libdesktop-agnostic/vfs-volume-impl-gio.vala 2013-10-28 00:18:43.450687804 +0100
+@@ -27,6 +27,7 @@
+ public class VolumeGIO : Object, Volume
+ {
+ private GLib.Volume vol;
++ private string? _name;
+ public GLib.Volume implementation
+ {
+ construct
+@@ -38,7 +39,9 @@
+ {
+ get
+ {
+- return this.vol.get_name ();
++ if (_name == null)
++ _name = (string)this.vol.get_name ();
++ return _name;
+ }
+ }
+ private File _uri;
+@@ -142,7 +145,7 @@
+ {
+ if (this._unmount_callback == null)
+ {
+- unowned Mount? mount;
++ Mount? mount;
+ this._unmount_callback = callback;
+ mount = this.vol.get_mount ();
+ if (mount != null)