summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSanskritFritz2015-06-14 00:41:16 +0200
committerSanskritFritz2015-06-14 00:41:16 +0200
commitf05a1245d1e579560e907468d888aaa03b804619 (patch)
tree162e34514cd5eaa25e441274889803ffc8882c7d
downloadaur-f05a1245d1e579560e907468d888aaa03b804619.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD43
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6eaf8be54a2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = libdesktop-agnostic-git
+ pkgdesc = Provides an extensible config API, a unified virtual fs API, and a desktop item editor for GLib-based projects.
+ pkgver = 2013.11.01
+ pkgrel = 1
+ url = https://github.com/p12tic/libdesktop-agnostic
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ makedepends = intltool
+ makedepends = vala
+ makedepends = gobject-introspection
+ depends = pygtk
+ optdepends = gconf: gconf configuration backend
+ provides = libdesktop-agnostic
+ conflicts = libdesktop-agnostic
+ backup = etc/xdg/libdesktop-agnostic/desktop-agnostic.ini
+ source = git://github.com/p12tic/libdesktop-agnostic.git
+ md5sums = SKIP
+
+pkgname = libdesktop-agnostic-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4fb8a322c33c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: SanskritFritz (gmail)
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+# Contributor: Jan "heftig" Steffens <jan.steffens@gmail.com>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+
+pkgname=libdesktop-agnostic-git
+_gitname=libdesktop-agnostic
+pkgver=2013.11.01
+pkgrel=1
+pkgdesc='Provides an extensible config API, a unified virtual fs API, and a desktop item editor for GLib-based projects.'
+arch=('i686' 'x86_64')
+url='https://github.com/p12tic/libdesktop-agnostic'
+license=('GPL' 'LGPL')
+depends=('pygtk')
+makedepends=('intltool' 'vala' 'gobject-introspection')
+optdepends=('gconf: gconf configuration backend')
+conflicts=('libdesktop-agnostic')
+provides=('libdesktop-agnostic')
+backup=("etc/xdg/libdesktop-agnostic/desktop-agnostic.ini")
+source=("git://github.com/p12tic/libdesktop-agnostic.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ git log -1 --format="%cd" --date=short | sed 's|-|.|g'
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+
+ export PYTHON=/usr/bin/python2
+ python2 ./waf configure --prefix=/usr --sysconfdir=/etc \
+ --config-backends=gconf,keyfile \
+ --vfs-backends=gio \
+ --desktop-entry-backends=gio,glib
+ python2 ./waf
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+
+ python2 ./waf install --destdir="$pkgdir"
+}