summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Johansen2022-10-17 21:18:44 +0200
committerDan Johansen2022-10-17 21:18:44 +0200
commit82dc4f59b4f2a1a2b15e03ac00ddc24f9e313654 (patch)
tree6b72bc8f50f0dc889108124ece941b81914d50cc
downloadaur-82dc4f59b4f2a1a2b15e03ac00ddc24f9e313654.tar.gz
initial commit, version 0.0.7
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..86b42d95ef4f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libdesq
+ pkgdesc = The DesQ library to handle X11 protocols, system calls, classes and functions to be used across the DesQ project.
+ pkgver = 0.0.7
+ pkgrel = 1
+ url = https://gitlab.com/DesQ/libdesq
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ makedepends = meson
+ makedepends = ninja
+ depends = qt5-base
+ source = https://gitlab.com/DesQ/libdesq/-/archive/v0.0.7/libdesq-v0.0.7.tar.gz
+ md5sums = 309dcac10d71352853c7eb69db60c2b1
+
+pkgname = libdesq
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ca22197b8d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Dan Johansen <strit@manjaro.org>
+
+## Build order:
+## libdesq -> libdesqui -> desq-session -> desq-shell
+
+pkgname=libdesq
+pkgver=0.0.7
+pkgrel=1
+pkgdesc="The DesQ library to handle X11 protocols, system calls, classes and functions to be used across the DesQ project."
+arch=('x86_64' 'aarch64')
+url="https://gitlab.com/DesQ/${pkgname}"
+license=('GPL3')
+depends=('qt5-base')
+makedepends=('meson' 'ninja')
+source=("https://gitlab.com/DesQ/${pkgname}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz")
+md5sums=('309dcac10d71352853c7eb69db60c2b1')
+
+build() {
+ cd "${pkgname}-v${pkgver}"
+ meson .build --prefix=/usr --buildtype=release
+ ninja -C .build
+}
+
+package() {
+ cd "${pkgname}-v${pkgver}"
+ DESTDIR="${pkgdir}" ninja -C .build install
+}