summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Johansen2022-10-17 21:18:54 +0200
committerDan Johansen2022-10-17 21:18:54 +0200
commit02cd687c9d0c4c8555060aa50ed77eaefad6a55c (patch)
tree9df49ba686b6f22019c49980e8d10a502f9fbd4f
downloadaur-02cd687c9d0c4c8555060aa50ed77eaefad6a55c.tar.gz
initial commit, version 0.0.7
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b4d7c67001e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libdesqui
+ pkgdesc = DesQ UI Library. This library contains all the common UI widget which are to be used across the DesQ Project.
+ pkgver = 0.0.7
+ pkgrel = 1
+ url = https://gitlab.com/DesQ/libdesqui
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ makedepends = meson
+ makedepends = ninja
+ depends = qt5-base
+ depends = libdesq
+ depends = dfl-layouts
+ source = https://gitlab.com/DesQ/libdesqui/-/archive/v0.0.7/libdesqui-v0.0.7.tar.gz
+ md5sums = 3144fee2ff70a6654d645471ab368036
+
+pkgname = libdesqui
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c617f8b39f18
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Dan Johansen <strit@manjaro.org>
+
+## Build order:
+## libdesq -> libdesqui -> desq-session -> desq-shell
+
+pkgname=libdesqui
+pkgver=0.0.7
+pkgrel=1
+pkgdesc="DesQ UI Library. This library contains all the common UI widget which are to be used across the DesQ Project."
+arch=('x86_64' 'aarch64')
+url="https://gitlab.com/DesQ/${pkgname}"
+license=('GPL3')
+depends=('qt5-base' 'libdesq' 'dfl-layouts')
+makedepends=('meson' 'ninja')
+source=("https://gitlab.com/DesQ/${pkgname}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz")
+md5sums=('3144fee2ff70a6654d645471ab368036')
+
+build() {
+ cd "${pkgname}-v${pkgver}"
+ meson .build --prefix=/usr --buildtype=release
+ ninja -C .build
+}
+
+package() {
+ cd "${pkgname}-v${pkgver}"
+ DESTDIR="${pkgdir}" ninja -C .build install
+}