summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGötz2024-03-02 17:51:40 -0500
committerGötz2024-03-02 18:52:07 -0500
commit4a1e216e599f0c2929e8bc12a1a5c9ce841b517c (patch)
treea1a6a9d0264b6612bf777c78a237699fa3ea1e84
parent5b354487c9fefb3686b9a5377b6836362464adaf (diff)
downloadaur-4a1e216e599f0c2929e8bc12a1a5c9ce841b517c.tar.gz
Update to 3.6.0-27
-rw-r--r--.SRCINFO8
-rw-r--r--Makefile21
-rw-r--r--PKGBUILD12
3 files changed, 27 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a49a1cb8fa3..9e5962fc84f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = libdicomscope-jni-bin
pkgdesc = OFFIS DICOM viewer (JNI files).
pkgver = 3.6.0
- pkgrel = 20.1
+ pkgrel = 27
url = https://dicom.offis.de/dscope.php.en
arch = i686
arch = x86_64
groups =
license = OFFIS
- depends = libdcmtk14
+ depends = libdcmtk17
provides = libdicomscope-jni
conflicts = libdicomscope-jni
replaces = libdicomscope-jni
replaces = dicomscope<3.6.0
options = !strip
options = !emptydirs
- source_x86_64 = https://mirrors.kernel.org/ubuntu/pool/universe/d/dicomscope/libdicomscope-jni_3.6.0-20build1_amd64.deb
- sha256sums_x86_64 = 80824e47379de237f5a5c4a118ef960cc2280f870544ccab0c2543e1b10dbc36
+ source_x86_64 = https://mirrors.kernel.org/ubuntu/pool/universe/d/dicomscope/libdicomscope-jni_3.6.0-27_amd64.deb
+ sha256sums_x86_64 = 662ab5f2d421c726902f9d2c1c52fa20f8601f672841d62d88a8162d1457b41d
pkgname = libdicomscope-jni-bin
diff --git a/Makefile b/Makefile
index 85fccd97b93c..2c2e83530317 100644
--- a/Makefile
+++ b/Makefile
@@ -1,3 +1,10 @@
+.SHELL = /usr/bin/env bash
+
+NAME = $(shell grep -m 1 pkgname .SRCINFO | cut -d '=' -f 2 | xargs)
+URL = $(shell grep url .SRCINFO | cut -d '=' -f 2 | xargs)
+VERSION = $(shell grep pkgver .SRCINFO | cut -d '=' -f 2 | xargs)
+RELEASE = $(shell grep pkgrel .SRCINFO | cut -d '=' -f 2 | xargs)
+
.PHONY: all
all: build git install
@@ -16,7 +23,7 @@ srcinfo:
.PHONY: makepkg
makepkg:
- makepkg -s
+ makepkg --syncdeps --force
.PHONY: build
build: geninteg srcinfo makepkg
@@ -29,16 +36,22 @@ git_add:
git add PKGBUILD .SRCINFO Makefile
.PHONY: git_commit
-git_commit: VERSION = "$(shell grep pkgver .SRCINFO | cut -d '=' -f 2 | tr -d '[:space:]')"
git_commit: GIT_STATUS = "$(shell git status --porcelain)"
git_commit:
- [ -n ${GIT_STATUS} ] && git commit -m "Update to ${VERSION}"
+ [ -n ${GIT_STATUS} ] && git commit -m "Update to ${VERSION}-${RELEASE}"
.PHONY: install
install:
makepkg --repackage --install --force
.PHONY: open
-open: URL = "$(shell grep url .SRCINFO | cut -d '=' -f 2 | tr -d '[:space:]')"
open:
xdg-open $(URL)
+
+.PHONY: run
+run:
+ env $(NAME)
+
+.PHONY: test
+test:
+ env $(NAME) --version
diff --git a/PKGBUILD b/PKGBUILD
index fa3ea280e9e3..c638b70752db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,28 +4,28 @@
pkgname=libdicomscope-jni-bin
_pkgname=libdicomscope-jni
pkgver=3.6.0
-pkgrel=20.1
-_pkgrel=20build1
+pkgrel=27
+_debrel=${pkgrel}
pkgdesc="OFFIS DICOM viewer (JNI files)."
arch=('i686' 'x86_64')
url="https://dicom.offis.de/dscope.php.en"
_url="https://packages.ubuntu.com/focal/libdicomscope-jni" # LTS
license=('OFFIS')
groups=('')
-depends=('libdcmtk14')
+depends=('libdcmtk17')
replaces=("${_pkgname}" 'dicomscope<3.6.0')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
options=('!strip' '!emptydirs')
-source_x86_64=("https://mirrors.kernel.org/ubuntu/pool/universe/d/dicomscope/${_pkgname}_${pkgver}-${_pkgrel}_amd64.deb")
+source_x86_64=("https://mirrors.kernel.org/ubuntu/pool/universe/d/dicomscope/${_pkgname}_${pkgver}-${_debrel}_amd64.deb")
package() {
- tar xf data.tar.xz -C "${pkgdir}"
+ tar xf data.tar.zst -C "${pkgdir}"
mv "${pkgdir}/usr/lib/x86_64-linux-gnu/jni" "${pkgdir}/usr/lib/"
rmdir "${pkgdir}/usr/lib/x86_64-linux-gnu/"
install -D -m644 "${pkgdir}/usr/share/doc/${_pkgname}/copyright" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
}
-sha256sums_x86_64=('80824e47379de237f5a5c4a118ef960cc2280f870544ccab0c2543e1b10dbc36')
+sha256sums_x86_64=('662ab5f2d421c726902f9d2c1c52fa20f8601f672841d62d88a8162d1457b41d')