summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkevku2021-12-23 15:41:40 +0200
committerkevku2021-12-23 15:41:40 +0200
commita62ff147449928dd93584cc8b3a00102e4ca04b1 (patch)
treeaa3b281777dad396f238a238ffce3e8e112cc7cf
parentc981a1571e1a565ea230af8beddf5abb8660c5b4 (diff)
downloadaur-a62ff147449928dd93584cc8b3a00102e4ca04b1.tar.gz
openssl-1.1.1m fix
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9339846a59a6..5a6b08369d83 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = libdigidocpp
pkgdesc = Library for creating, signing and verification of digitally signed documents, according to XAdES and XML-DSIG standards
pkgver = 3.14.7.1412
- pkgrel = 1
+ pkgrel = 2
url = http://www.id.ee/
arch = x86_64
arch = i686
license = LGPL
makedepends = cmake
+ makedepends = git
makedepends = xsd
makedepends = xxd
- makedepends = git
- depends = xml-security-c
depends = minizip
+ depends = openssl
+ depends = xalan-c
+ depends = xml-security-c
source = libdigidocpp-3.14.7.1412::git+https://github.com/open-eid/libdigidocpp.git?signed#tag=v3.14.7
source = open-eid-cmake::git+https://github.com/open-eid/cmake.git
validpgpkeys = D1EBC666EFCBFBD3CFC2EBAA90C0B5E75C3B195D
diff --git a/PKGBUILD b/PKGBUILD
index a40d97ca2758..196d9c4288a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=libdigidocpp
pkgver=3.14.7.1412
_rls_tag=v3.14.7
-pkgrel=1
+pkgrel=2
pkgdesc="Library for creating, signing and verification of digitally signed documents, according to XAdES and XML-DSIG standards"
arch=('x86_64' 'i686')
url="http://www.id.ee/"
license=('LGPL')
-depends=('xml-security-c' 'minizip')
-makedepends=('cmake' 'xsd' 'xxd' 'git')
+depends=('minizip' 'openssl' 'xalan-c' 'xml-security-c')
+makedepends=('cmake' 'git' 'xsd' 'xxd')
source=("$pkgname-$pkgver::git+https://github.com/open-eid/libdigidocpp.git?signed#tag=$_rls_tag"
"open-eid-cmake::git+https://github.com/open-eid/cmake.git")
sha256sums=("SKIP" "SKIP")
@@ -24,6 +24,8 @@ prepare() {
git submodule init
git config submodule.cmake.url $srcdir/open-eid-cmake
git submodule update
+ # openssl 1.1.1m https://github.com/open-eid/libdigidocpp/pull/453
+ git checkout 692b310f69636b020a75ffd60b11dbf6495f7a12 src/crypto/TS.cpp
}
build() {