summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkevku2017-06-30 11:10:22 +0300
committerkevku2017-06-30 11:10:22 +0300
commitd9df1e53cba39a9cfa02f4833d4d0b57d5e46a88 (patch)
tree2409776720e962399e87ab6d5ec151f0763a48ab
parentc10cc69ff6e9f7e6ec3882bd5ea1ea14f78cacff (diff)
downloadaur-d9df1e53cba39a9cfa02f4833d4d0b57d5e46a88.tar.gz
3.13.0.1353
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
-rw-r--r--fix-compile-3.13.0.1353.patch11
3 files changed, 24 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d28922550e9..ce5d92d29083 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libdigidocpp
pkgdesc = Library for creating DigiDoc signature files
- pkgver = 3.12.3.1341
- pkgrel = 2
+ pkgver = 3.13.0.1353
+ pkgrel = 1
url = http://www.id.ee/
arch = x86_64
arch = i686
@@ -13,9 +13,11 @@ pkgbase = libdigidocpp
makedepends = xxd
depends = xml-security-c
depends = libdigidoc
- source = https://installer.id.ee/media/ubuntu/pool/main/libd/libdigidocpp/libdigidocpp_3.12.3.1341.orig.tar.xz
+ source = https://installer.id.ee/media/ubuntu/pool/main/libd/libdigidocpp/libdigidocpp_3.13.0.1353.orig.tar.xz
+ source = fix-compile-3.13.0.1353.patch
validpgpkeys = 43650273CE9516880D7EB581B339B36D592073D4
- sha256sums = d0f190f02fdc6cfdd48da64fff04623edfdc459411cbee4b613123dda03b8f60
+ sha256sums = fc34c1344891dfebc28e539858d2c72942014469e8deabba57bbae3a5c4ade50
+ sha256sums = 995880ab4f84f01fbe44b6b4a87c0d70fbf534e4ecf7969e751a008841e94afe
pkgname = libdigidocpp
diff --git a/PKGBUILD b/PKGBUILD
index 1b017b58c8b0..2268fe701ab6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,22 @@
# Maintainer: kevku <kevku@gmx.com>
pkgname=libdigidocpp
-pkgver=3.12.3.1341
-pkgrel=2
+pkgver=3.13.0.1353
+pkgrel=1
pkgdesc="Library for creating DigiDoc signature files"
arch=('x86_64' 'i686')
url="http://www.id.ee/"
license=('LGPL')
depends=('xml-security-c' 'libdigidoc')
makedepends=('cmake' 'xsd>=4.0' 'pcsclite' 'opensc' 'xxd')
-source=("https://installer.id.ee/media/ubuntu/pool/main/libd/$pkgname/${pkgname}_$pkgver.orig.tar.xz")
-sha256sums=('d0f190f02fdc6cfdd48da64fff04623edfdc459411cbee4b613123dda03b8f60')
+source=("https://installer.id.ee/media/ubuntu/pool/main/libd/$pkgname/${pkgname}_$pkgver.orig.tar.xz"
+ "fix-compile-3.13.0.1353.patch")
+sha256sums=('fc34c1344891dfebc28e539858d2c72942014469e8deabba57bbae3a5c4ade50'
+ '995880ab4f84f01fbe44b6b4a87c0d70fbf534e4ecf7969e751a008841e94afe')
validpgpkeys=('43650273CE9516880D7EB581B339B36D592073D4')
build() {
cd "$srcdir/"
+ patch -p1 -i fix-compile-3.13.0.1353.patch
export PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig
cmake . -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR="lib" -DCMAKE_INSTALL_SYSCONFDIR="/etc" -DINSTALL_DOC=NO -DSWIG_EXECUTABLE="" -DBoost_INCLUDE_DIR="" -DMINIZIP_INCLUDE_DIR=""
make
diff --git a/fix-compile-3.13.0.1353.patch b/fix-compile-3.13.0.1353.patch
new file mode 100644
index 000000000000..192915b153ec
--- /dev/null
+++ b/fix-compile-3.13.0.1353.patch
@@ -0,0 +1,11 @@
+--- src/src/crypto/Connect.cpp 2017-06-14 16:45:01.000000000 +0300
++++ src/src/crypto/Connect.cpp.new 2017-06-30 11:02:51.189677609 +0300
+@@ -30,6 +30,8 @@
+ #include <zlib.h>
+
+ #include <thread>
++#include <functional>
++#include <cstring>
+
+ #ifdef __ANDROID__
+ #include <sys/select.h>