summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2019-12-23 06:31:41 -0700
committerBrian Bidulock2019-12-23 06:31:41 -0700
commitfeff25e1518e84d4db6e57f5d1689f98c702dc06 (patch)
treec10cca59c98a9660454e625efd4d3c446fcbcbd7
downloadaur-feff25e1518e84d4db6e57f5d1689f98c702dc06.tar.gz
initial version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..41d063a574f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libdmx
+ pkgdesc = X11 Distributed Multihead extension library
+ pkgver = 1.1.4
+ pkgrel = 2
+ url = https://xorg.freedesktop.org/
+ arch = x86_64
+ arch = i686
+ license = custom
+ makedepends = xorg-util-macros
+ depends = libxext
+ source = https://www.x.org/releases/individual/lib/libdmx-1.1.4.tar.bz2
+ sha256sums = 253f90005d134fa7a209fbcbc5a3024335367c930adf0f3203e754cf32747243
+
+pkgname = libdmx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3799fe89684e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+
+pkgname=libdmx
+pkgver=1.1.4
+pkgrel=2
+pkgdesc='X11 Distributed Multihead extension library'
+arch=('x86_64' 'i686')
+license=('custom')
+url='https://xorg.freedesktop.org/'
+depends=('libxext')
+makedepends=('xorg-util-macros')
+source=("https://www.x.org/releases/individual/lib/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('253f90005d134fa7a209fbcbc5a3024335367c930adf0f3203e754cf32747243')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./configure \
+ --prefix='/usr' \
+ --disable-static
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+ install -Dm 644 COPYING -t "${pkgdir}"/usr/share/licenses/${pkgname}/
+}
+
+# vim: ts=2 sw=2 et: