summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLW-archlinux2015-12-23 16:05:17 +0100
committerLW-archlinux2015-12-23 16:05:17 +0100
commit8d0247cc7439a4905505567ff45aa37e6f61f279 (patch)
tree728c7bf94572baa7addad10b1cff74106061d8f5
downloadaur-8d0247cc7439a4905505567ff45aa37e6f61f279.tar.gz
first version
-rw-r--r--.SRCINFO26
-rw-r--r--COPYING48
-rw-r--r--PKGBUILD52
3 files changed, 126 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ddf85816c563
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Wed Dec 23 13:59:12 UTC 2015
+pkgbase = libdrm-git
+ pkgdesc = Userspace interface to kernel DRM services, master git version
+ pkgver = 5795.b38a4b2
+ pkgrel = 2
+ url = http://dri.freedesktop.org/
+ arch = i686
+ arch = x86_64
+ license = custom
+ checkdepends = cairo
+ checkdepends = cunit
+ makedepends = valgrind
+ makedepends = xorg-util-macros
+ depends = glibc
+ depends = libpciaccess
+ provides = libdrm=2.4.66
+ conflicts = libdrm
+ replaces = libdrm
+ source = libdrm::git://anongit.freedesktop.org/mesa/drm#branch=master
+ source = COPYING
+ sha256sums = SKIP
+ sha256sums = 9631d4f694952e3e6ae5a05534c2e93e994e47d3413677a3a00e45c8cef6db93
+
+pkgname = libdrm-git
+
diff --git a/COPYING b/COPYING
new file mode 100644
index 000000000000..6e74c337c3b9
--- /dev/null
+++ b/COPYING
@@ -0,0 +1,48 @@
+ Copyright 2005 Adam Jackson.
+
+ Permission is hereby granted, free of charge, to any person obtaining
+ a copy of this software and associated documentation files (the
+ "Software"), to deal in the Software without restriction, including
+ without limitation on the rights to use, copy, modify, merge,
+ publish, distribute, sub license, and/or sell copies of the Software,
+ and to permit persons to whom the Software is furnished to do so,
+ subject to the following conditions:
+
+ The above copyright notice and this permission notice (including the
+ next paragraph) shall be included in all copies or substantial
+ portions of the Software.
+
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+ EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+ MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+ NON-INFRINGEMENT. IN NO EVENT SHALL ADAM JACKSON BE LIABLE FOR ANY
+ CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
+ TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+ SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+------------------------------------------------------------------------
+
+ Copyright 1999 Precision Insight, Inc., Cedar Park, Texas.
+ Copyright 2000 VA Linux Systems, Inc., Sunnyvale, California.
+ All Rights Reserved.
+
+ Permission is hereby granted, free of charge, to any person obtaining
+ a copy of this software and associated documentation files (the
+ "Software"), to deal in the Software without restriction, including
+ without limitation the rights to use, copy, modify, merge, publish,
+ distribute, sublicense, and/or sell copies of the Software, and to
+ permit persons to whom the Software is furnished to do so, subject to
+ the following conditions:
+
+ The above copyright notice and this permission notice (including the
+ next paragraph) shall be included in all copies or substantial
+ portions of the Software.
+
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+ EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+ MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+ NONINFRINGEMENT. IN NO EVENT SHALL PRECISION INSIGHT AND/OR ITS
+ SUPPLIERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+ WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+ DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98901f3ce76c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer : Lone_Wolf <lonewolf at xs4all dot nl>
+# Contributor : Jan de Groot <jgc@archlinux.org>
+
+pkgname=libdrm-git
+_pkgname=libdrm
+pkgver=5795.b38a4b2
+pkgrel=2
+pkgdesc="Userspace interface to kernel DRM services, master git version"
+arch=(i686 x86_64)
+license=('custom')
+depends=('glibc' 'libpciaccess')
+makedepends=('valgrind' 'xorg-util-macros')
+checkdepends=('cairo' 'cunit')
+url="http://dri.freedesktop.org/"
+provides=('libdrm=2.4.66')
+replaces=('libdrm')
+conflicts=('libdrm')
+
+source=('libdrm::git://anongit.freedesktop.org/mesa/drm#branch=master'
+ COPYING)
+sha256sums=('SKIP'
+ '9631d4f694952e3e6ae5a05534c2e93e994e47d3413677a3a00e45c8cef6db93')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+prepare() {
+ cd ${_pkgname}
+
+ # pthread is useless in Linux
+ sed -i "/pthread-stubs/d" configure.ac
+}
+
+build() {
+ cd ${_pkgname}
+ ./autogen.sh --prefix=/usr --enable-udev
+ make
+}
+
+check() {
+ cd ${_pkgname}
+ make -k check
+}
+
+package() {
+ cd ${_pkgname}
+ make DESTDIR="$pkgdir" install
+ install -m755 -d "$pkgdir/usr/share/licenses/$pkgname"
+ install -m644 ${srcdir}/COPYING "$pkgdir/usr/share/licenses/$pkgname/"
+}