summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Reimer2015-08-10 13:29:54 +0200
committerChristopher Reimer2015-08-10 13:29:54 +0200
commit3c0949702bcee99e5b562c71f3cfd956877b1a63 (patch)
treecdad083a5b6589385c21200e8baadea53b4ba423
downloadaur-3c0949702bcee99e5b562c71f3cfd956877b1a63.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/7f69ddab9523aff9d6ed3ca4c5b511d9ad07e879)
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a28ad3cfdba4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libdvbcsa
+ pkgdesc = A free implementation of the DVB Common Scrambling Algorithm
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = http://www.videolan.org/developers/libdvbcsa.html
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = GPL3
+ depends = glibc
+ source = http://download.videolan.org/pub/videolan/libdvbcsa/1.1.0/libdvbcsa-1.1.0.tar.gz
+ md5sums = 478ab1ca56ca58d2667da6ce22f74e39
+
+pkgname = libdvbcsa
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89ee61aa17fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
+# Contributor: Alexandre Becoulet <alexandre.becoulet@free.fr>
+
+pkgname=libdvbcsa
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="A free implementation of the DVB Common Scrambling Algorithm"
+arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
+url="http://www.videolan.org/developers/libdvbcsa.html"
+license=('GPL3')
+depends=('glibc')
+source=("http://download.videolan.org/pub/videolan/libdvbcsa/$pkgver/$pkgname-$pkgver.tar.gz")
+md5sums=('478ab1ca56ca58d2667da6ce22f74e39')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+} \ No newline at end of file