summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-08-12 16:16:24 +0800
committerChocobo12017-08-12 16:16:24 +0800
commit766e627ef0f49abdee99abcca7a78de89eec27e5 (patch)
tree9a7622664cc1688cc605fbfdfe9f8671fd4ed84e
downloadaur-766e627ef0f49abdee99abcca7a78de89eec27e5.tar.gz
newpkg: libdvbcsa-git 1:bc6c0b1-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb7ee23e448a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libdvbcsa-git
+ pkgdesc = An implementation of the DVB Common Scrambling Algorithm
+ pkgver = bc6c0b1
+ pkgrel = 1
+ epoch = 1
+ url = https://www.videolan.org/developers/libdvbcsa.html
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = glibc
+ provides = libdvbcsa
+ conflicts = libdvbcsa
+ source = git+https://code.videolan.org/videolan/libdvbcsa.git
+ sha256sums = SKIP
+
+pkgname = libdvbcsa-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b8f7f465615
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libdvbcsa-git
+pkgver=bc6c0b1
+pkgrel=1
+epoch=1
+pkgdesc="An implementation of the DVB Common Scrambling Algorithm"
+arch=('i686' 'x86_64')
+url="https://www.videolan.org/developers/libdvbcsa.html"
+license=('GPL2')
+depends=('glibc')
+makedepends=('git')
+provides=('libdvbcsa')
+conflicts=('libdvbcsa')
+source=("git+https://code.videolan.org/videolan/libdvbcsa.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "libdvbcsa"
+
+ git describe --always
+}
+
+build() {
+ cd "libdvbcsa"
+
+ ./bootstrap
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "libdvbcsa"
+
+ make check
+}
+
+package() {
+ cd "libdvbcsa"
+
+ make DESTDIR="$pkgdir" install
+}