summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-01-16 08:55:30 +0100
committerGustavo Alvarez2016-01-16 08:55:30 +0100
commitc51c5a15531288fac7e5a3d88b7758024d47ae83 (patch)
treef8ada02c6977549b4a5260d56adc34aeae917708
downloadaur-c51c5a15531288fac7e5a3d88b7758024d47ae83.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD31
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f0fd290a19b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sat Jan 16 07:55:30 UTC 2016
+pkgbase = libdvd-audio-git
+ pkgdesc = A C library for extracting audio from DVD-Audio discs. (GIT version)
+ pkgver = v1.0.0.3.gc74bdfc
+ pkgrel = 1
+ url = http://libdvd-audio.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = glibc
+ provides = libdvd-audio
+ conflicts = libdvd-audio
+ source = git+https://github.com/tuffy/libdvd-audio.git
+ sha1sums = SKIP
+
+pkgname = libdvd-audio-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..674b6a2ada73
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgname=libdvd-audio-git
+pkgver=v1.0.0.3.gc74bdfc
+pkgrel=1
+pkgdesc="A C library for extracting audio from DVD-Audio discs. (GIT version)"
+arch=('i686' 'x86_64')
+url='http://libdvd-audio.sourceforge.net'
+license=('GPL')
+depends=('glibc')
+makedepends=('git')
+provides=('libdvd-audio')
+conflicts=('libdvd-audio')
+source=('git+https://github.com/tuffy/libdvd-audio.git')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd libdvd-audio
+ echo "$(git describe --always | tr - .)"
+}
+
+build() {
+ cd libdvd-audio
+ make
+}
+
+package() {
+ cd libdvd-audio
+ install -d ${pkgdir}/usr/{include,bin,lib{,/pkgconfig}}
+ make BIN_DIR=${pkgdir}/usr/bin LIB_DIR=${pkgdir}/usr/lib INCLUDE_DIR=${pkgdir}/usr/include LIB_DIR=${pkgdir}/usr/lib PKG_CONFIG_DIR=${pkgdir}/usr/lib/pkgconfig install
+}