summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 17:28:21 +0200
committersl1pkn072015-06-08 17:28:21 +0200
commit8bce0150fb0a461e2ad67f1dca3c96b59c704c5b (patch)
treeb6c50c42842a4c391831cb4648c0494704b7ced7
downloadaur-8bce0150fb0a461e2ad67f1dca3c96b59c704c5b.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..753bcc46845a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libdvdread-git
+ pkgdesc = Library to access DVD disks. (GIT version)
+ pkgver = 5.0.1.12.gd14f83e
+ pkgrel = 1
+ url = http://dvdnav.mplayerhq.hu
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = libdvdcss-git
+ provides = libdvdread
+ conflicts = libdvdread
+ source = git://git.videolan.org/libdvdread.git
+ sha1sums = SKIP
+
+pkgname = libdvdread-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47cc4fe5e726
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgname=libdvdread-git
+pkgver=5.0.1.12.gd14f83e
+pkgrel=1
+pkgdesc="Library to access DVD disks. (GIT version)"
+arch=('i686' 'x86_64')
+url="http://dvdnav.mplayerhq.hu"
+license=('GPL2')
+depends=('libdvdcss-git')
+makedepends=('git')
+provides=('libdvdread')
+conflicts=('libdvdread')
+source=("git://git.videolan.org/libdvdread.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd libdvdread
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ cd libdvdread
+ autoreconf -if
+}
+
+build() {
+ cd libdvdread
+ ./configure --prefix=/usr --enable-static=no --with-libdvdcss
+ make
+}
+
+package() {
+ make -C libdvdread DESTDIR="${pkgdir}" install
+}