summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShenghao Yang2018-05-13 23:13:54 +0800
committerShenghao Yang2018-05-13 23:13:54 +0800
commit3f1bb7c784b9827413791698c227475884ce44b3 (patch)
treec0da4792c07ab0c6a5fecc0ef509dbad788b4164
downloadaur-3f1bb7c784b9827413791698c227475884ce44b3.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD39
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..876001a0b158
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libe131-git
+ pkgdesc = A lightweight C/C++ library for the E1.31 (sACN) protocol
+ pkgver = 1.3.1.r4.g9e0d1fc
+ pkgrel = 1
+ url = https://github.com/hhromic/libe131
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = Apache
+ makedepends = git
+ provides = libe131
+ conflicts = libe131
+ source = git+https://github.com/hhromic/libe131.git
+ md5sums = SKIP
+
+pkgname = libe131-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6b50e0837f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Shenghao Yang <me@shenghaoyang.info>
+pkgname=libe131-git
+pkgver=1.3.1.r4.g9e0d1fc
+pkgrel=1
+pkgdesc="A lightweight C/C++ library for the E1.31 (sACN) protocol"
+arch=('x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url='https://github.com/hhromic/libe131'
+license=('Apache')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+${url}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ autoreconf --install --force
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$srcdir/${pkgname%-git}"
+ make -k check
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="$pkgdir/" install
+} \ No newline at end of file