summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Weißschuh2022-11-30 05:07:02 +0100
committerThomas Weißschuh2022-11-30 05:08:56 +0100
commit1dbcded546c4e2c656961b2dbc547b19169fa9b6 (patch)
treebc9fae208e02035dfb5e5575a6fc26e856adc6ea
downloadaur-1dbcded546c4e2c656961b2dbc547b19169fa9b6.tar.gz
Initial upload: libeconf 0.4.9-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD33
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..516557f41817
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = libeconf
+ pkgdesc = Enhanced config file parser, which merges config files placed in several locations into one.
+ pkgver = 0.4.9
+ pkgrel = 1
+ url = https://opensuse.github.io/libeconf/
+ arch = x86_64
+ license = MIT
+ makedepends = meson
+ source = libeconf-0.4.9.tar.gz::https://github.com/openSUSE/libeconf/archive/refs/tags/v0.4.9.tar.gz
+ md5sums = c2523f6987c436a44b92917a028cbf7c
+
+pkgname = libeconf
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..363e8e318305
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Thomas Weißschuh <thomas t-8ch de>
+
+pkgname=libeconf
+pkgver=0.4.9
+pkgrel=1
+pkgdesc="Enhanced config file parser, which merges config files placed in several locations into one."
+arch=(x86_64)
+url="https://opensuse.github.io/libeconf/"
+license=('MIT')
+depends=()
+makedepends=(meson)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/openSUSE/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
+md5sums=('c2523f6987c436a44b92917a028cbf7c')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ arch-meson build
+ meson compile -C build
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ meson install -C build --destdir "$pkgdir"
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}