summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Haag2017-02-06 18:54:32 +0100
committerChristoph Haag2017-02-06 18:54:32 +0100
commit473f8930a0688337ea679b581d374367a3d0a5b9 (patch)
tree10e011866d8f3e2fde87f40e2cbcfb8ab3a07da5
parent5503702191818828f9e905521d8e88d64bd4bc06 (diff)
downloadaur-473f8930a0688337ea679b581d374367a3d0a5b9.tar.gz
update with whatever that guy in the comments said
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD29
2 files changed, 15 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index edbfea078524..cefbf8180351 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libepoxy-git
pkgdesc = Epoxy is a library for handling OpenGL function pointer management for you
- pkgver = 1.2.25.r229.ga2a5190
+ pkgver = 1.4.0.r0.g9628670
pkgrel = 1
url = https://github.com/anholt/libepoxy
arch = i686
@@ -10,9 +10,9 @@ pkgbase = libepoxy-git
makedepends = libx11
makedepends = python
makedepends = git
+ makedepends = meson
provides = libepoxy
conflicts = libepoxy
- options = !libtool
source = git+https://github.com/anholt/libepoxy.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 43aab84d1b00..8edbfbfdd319 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,38 @@
pkgname=libepoxy-git
_name=libepoxy
-pkgver=1.2.25.r229.ga2a5190
+pkgver=1.4.0.r0.g9628670
pkgrel=1
pkgdesc="Epoxy is a library for handling OpenGL function pointer management for you"
url="https://github.com/anholt/libepoxy"
arch=('i686' 'x86_64')
license=('BSD')
-depends=() # ???
-makedepends=("xorg-util-macros" "libx11" "python" "git")
+makedepends=("xorg-util-macros" "libx11" "python" "git" "meson")
provides=("libepoxy")
conflicts=("libepoxy")
-options=('!libtool')
source=("git+https://github.com/anholt/libepoxy.git")
+md5sums=('SKIP')
pkgver() {
cd $_name
- #echo $(git rev-list --count HEAD).$(git describe --tags --long | tr -d v | tr - .)
- echo $(git describe --long --tags | cut -d 'g' -f1)r$(git rev-list HEAD --count).g$(git describe --always) | tr -d v | tr - .
+
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- # export CFLAGS="-Og -ggdb"
- # export CXXFLAGS="-Og -ggdb"
cd "$_name"
- ./autogen.sh --prefix=/usr
- #./configure --prefix=/usr
+ rm -rf _build
+ meson _build --buildtype=release --prefix=/usr
+ ninja -C _build
}
#check() {
-# cd "$_name"
-# make -k check
+# cd "$_name/_build"
+#
+# ninja test
#}
package() {
- cd "$_name"
- make DESTDIR="$pkgdir" install
+ cd "$_name/_build"
+ env DESTDIR="$pkgdir" ninja install
}
-
-md5sums=('SKIP')